Bug #38106 main.crash_commit_before crashes the server sporadically
Submitted: 14 Jul 2008 15:21 Modified: 17 Oct 2008 8:48
Reporter: Alexander Nozdrin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version:6.0-BK OS:Any
Assigned to: CPU Architecture:Any
Tags: crash, pushbuild, sporadic, test failure
Triage: Triaged: D1 (Critical)

[14 Jul 2008 15:21] Alexander Nozdrin
Description:
main.crash_commit_before       [ fail ]

mysqltest: In included file "./include/wait_until_connected_again.inc": At line 20: Server failed to restart

The result from queries just before the failure was:
CREATE TABLE t1(a int) engine=innodb;
START TRANSACTION;
insert into t1 values(9);
SET SESSION debug="d,crash_commit_before";
COMMIT;
ERROR HY000: Lost connection to MySQL server during query

How to repeat:
https://intranet.mysql.com/secure/pushbuild/xref.pl?testname=main.crash_commit_before
[17 Oct 2008 8:48] Alexander Nozdrin
It's a duplicate of Bug#37810.