Bug #37810 The server crashes sporadically in wait_until_connected_again.inc
Submitted: 2 Jul 2008 16:55 Modified: 8 Jun 2009 20:00
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S7 (Test Cases)
Version:6.0-BK OS:Any
Assigned to: Horst Hunger CPU Architecture:Any
Tags: crash, pushbuild, sporadic, test failure, widespread
Triage: Triaged: D3 (Medium)

[2 Jul 2008 16:55] Alexander Nozdrin
Description:
mysqltest: In included file "./include/wait_until_connected_again.inc": At line 12: query 'show status' failed with wrong errno 2013: 'Lost connection to MySQL server at 'reading initial communication packet', system error: 54', instead of 0...

The result from queries just before the failure was:
< snip >
Table	Op	Msg_type	Msg_text
mysqltest.t1	check	status	OK
* testing that checksum after recovery is as expected
Checksum-check
ok
use mysqltest;
show keys from t1;
Table	Non_unique	Key_name	Seq_in_index	Column_name	Collation	Cardinality	Sub_part	Packed	Null	Index_type	Comment	Index_Comment
t1	1	a	1	a	A	1	NULL	NULL	YES	BTREE		
drop table t1;
* TEST of recovery when OPTIMIZE has replaced the index file and crash
create table t_corrupted1 (a varchar(100), key(a)) engine=maria;
insert into t_corrupted1 select (rand()) from t2;
flush table t_corrupted1;
* copied t_corrupted1 for comparison
SET SESSION debug="+d,maria_flush_whole_log,maria_flush_whole_page_cache,maria_crash_sort_index";
* crashing mysqld intentionally
optimize table t_corrupted1;
ERROR HY000: Lost connection to MySQL server during query
* recovery happens

How to repeat:
https://intranet.mysql.com/secure/pushbuild/xref.pl?testname=main.maria-recovery2

Date: 2008-07-01
[4 Jul 2008 8:27] Alexander Nozdrin
https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-6.0-falcon&order=39

Date: 2008-Jul-03
[14 Jul 2008 12:35] Sergei Golubchik
I failed to repeat the bug and it doesn't show up in pushbuild anymore.
This, I'm closing the bugreport.

Please reopen it if the problem will appear again.
[11 Aug 2008 7:58] Alexander Nozdrin
Based on discussion with Jani, the following failures belong to Maria:

https://intranet.mysql.com/secure/pushbuild/xref.pl?startdate=&enddate=&dir=&plat=&testtyp...

Reopening the bug.
[17 Oct 2008 8:50] Alexander Nozdrin
Bug#38106 was marked as a duplicate of this bug.
See also Bug#39903.
[18 Oct 2008 16:47] Sven Sandberg
BUG#39903 is probably something different (see comment in BUG#39903)
[15 Jan 2009 6:36] Bugs System
Pushed into 5.1.31 (revid:joro@sun.com-20090115053147-tx1oapthnzgvs1ro) (version source revid:azundris@mysql.com-20081230114838-cn52tu180wcrvh0h) (merge vers: 5.1.31) (pib:6)
[19 Jan 2009 11:28] Bugs System
Pushed into 5.1.31-ndb-6.2.17 (revid:tomas.ulin@sun.com-20090119095303-uwwvxiibtr38djii) (version source revid:tomas.ulin@sun.com-20090115073240-1wanl85vlvw2she1) (merge vers: 5.1.31-ndb-6.2.17) (pib:6)
[19 Jan 2009 13:06] Bugs System
Pushed into 5.1.31-ndb-6.3.21 (revid:tomas.ulin@sun.com-20090119104956-guxz190n2kh31fxl) (version source revid:tomas.ulin@sun.com-20090119104956-guxz190n2kh31fxl) (merge vers: 5.1.31-ndb-6.3.21) (pib:6)
[19 Jan 2009 16:11] Bugs System
Pushed into 5.1.31-ndb-6.4.1 (revid:tomas.ulin@sun.com-20090119144033-4aylstx5czzz88i5) (version source revid:tomas.ulin@sun.com-20090119144033-4aylstx5czzz88i5) (merge vers: 5.1.31-ndb-6.4.1) (pib:6)
[20 Jan 2009 18:58] Bugs System
Pushed into 6.0.10-alpha (revid:joro@sun.com-20090119171328-2hemf2ndc1dxl0et) (version source revid:azundris@mysql.com-20081230114916-c290n83z25wkt6e4) (merge vers: 6.0.9-alpha) (pib:6)
[8 Jun 2009 20:00] Paul Dubois
Test case changes. No changelog entry needed.