Bug #3799 WinMySQLAdmin shows no server info
Submitted: 17 May 2004 15:23 Modified: 14 Sep 2008 2:34
Reporter: Aaron Hayward Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.0.18 OS:Microsoft Windows (Windows XP Pro)
Assigned to: Miguel Solorzano CPU Architecture:Any

[17 May 2004 15:23] Aaron Hayward
Description:
I have recently upgraded from MySQL 3.23 to MySQL 4. Upon upgrading (which I ended up doing twice, once from scratch) the WinMySQLAdmin doesn't show any of the server info that it used to (such as the uptime / open tables / slow queries on the 'Environment' tab or the databases and tables on the 'Database' tab). The sever still runs correctly (my PHP scripts using it work and both MySQL-CC and MySQL Administrator still work properly) and the traffic lights correctly indicate the server status.

How to repeat:
Upgrade from MySQL 3.23 to MySQL 4.0 as per the instuctions in the documentation (for Windows). After the first run of the server you may need to end the process using Ctrl+Alt+Del since it doesn't seem to end correctly and this leads to the error 1067 as reported in the documentation. Start the service using WinMySQLAdmin.
[19 May 2004 5:23] Miguel Solorzano
Are the username and password keys under section [WinMySQLAdmin] in
the my.ini file an actual user in the new 4.0.18 server ?
[19 May 2004 7:35] Aaron Hayward
Ahh...the new my.ini file had no user/password keys. Adding them fixed it. Thanks.
[14 Feb 2005 22:54] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[9 Jul 2008 13:38] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/49309

2655 Rafal Somla	2008-07-09
      BUG#3799 (backup_commit_blocker test hangs):
      
      The problem is that SELECTing from INFORMATION_SCHEMA.PROCESSLIST (to show state
      of the threads) is not realiable and hangs sometimes.
      
      This patch comments-out selects from INFORMATION_SCHEMA.PROCESSLIST as they
      are not essential for the test.
[13 Sep 2008 23:51] Bugs System
Pushed into 6.0.7-alpha  (revid:rsomla@mysql.com-20080709133703-j7fqq9igk6dpbfax) (version source revid:timothy.smith@sun.com-20080813063149-5o63l7vlvbm6nuhm) (pib:3)