Bug #37884 rpl_row_basic_2myisam and rpl_row_basic_3innodb fail sporadically in pushbuild
Submitted: 4 Jul 2008 16:31 Modified: 12 Aug 2008 17:25
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Row Based Replication ( RBR ) Severity:S2 (Serious)
Version:5.1.26-rc OS:Any
Assigned to: Sven Sandberg CPU Architecture:Any
Tags: disabled, pushbuild, rpl_row_basic_2myisam, rpl_row_basic_3innodb, sporadic, test failure
Triage: D3 (Medium)

[4 Jul 2008 16:31] Joerg Bruehe
Description:
Detected in the build of 5.1.26-rc.

Sadly, 5.1.24 and 5.1.25 have not been checked in comparable depth,
so I cannot say whether these failures are new or just un-reported.

In the logs evaluated till now, test "rpl_row_basic_2myisam" (in row mode)
was run 490 times, of which 363 passed and 127 failed.

I file separate reports for failures which show distinct symptoms,
I cannot say how close they are related.

This is the fourth symptom, for the other ones see bug#37879, bug#37882, and bug#37883.

::::::::::::::
rpl.rpl_row_basic_2myisam 'row' [ fail ]

mysqltest: In included file "./include/diff_tables.inc": At line 117: command "diff_files" failed with error 2

The result from queries just before the failure was:
< snip >
Last_SQL_Error
Table definition on master and slave does not match: Column 1 size mismatch - master has size 765, test.t5 on
slave has size 49. Master's column size should be <= the slave's column size.
SET GLOBAL SQL_SLAVE_SKIP_COUNTER=8;
START SLAVE;
[expecting slave to stop]
INSERT INTO t6 VALUES (1, "", 1);
INSERT INTO t6 VALUES (2, repeat(_utf8'a', 255), 2);
Last_SQL_Error
Table definition on master and slave does not match: Column 1 size mismatch - master has size 765, test.t6 on
slave has size 385. Master's column size should be <= the slave's column size.
SET GLOBAL SQL_SLAVE_SKIP_COUNTER=8;
START SLAVE;
[expecting slave to replicate correctly]
INSERT INTO t7 VALUES (1, "", 1);
INSERT INTO t7 VALUES (2, repeat(_utf8'a', 255), 2);
Comparing tables master:test.t7 and slave:test.t7
--- /PATH/mysql-test/var/tmp/diff_table_1
+++ /PATH/mysql-test/var/tmp/diff_table_2
@@ -1,2 +1 @@
 1              1
-2      aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa     2
::::::::::::::

8 failures in total,
among them Solaris 10 (x86) (4 times).

How to repeat:
Run the test suite.
[4 Jul 2008 17:03] Joerg Bruehe
The other failures of this test are reported as
bug#37879, bug#37882, and bug#37883.

The very same symptom occurs in test "rpl_row_basic_3innodb",
the only difference being the path names (obviously)
and the exact distribution of occurrences across the platforms.

4 of the 121 failures of that test look like shown here.
[15 Jul 2008 15:33] Joe Grasse
I too was having this problem, and I have posted my observations and
a fixed test file to bug#37879. These bugs are caused by the same 
problem, IMHO.
[18 Jul 2008 10:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/50018

2719 Sven Sandberg	2008-07-18
      BUG#37884: Failures in rowbased replication: Test "rpl_row_basic_{2myisam,3innodb}" (4)
      Problem: sync_slave_with_master was missing, causing result
      mismatch.
      Fix: added sync_slave_with_master.
[18 Jul 2008 10:31] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/50019

2719 Sven Sandberg	2008-07-18
      BUG#37884: rpl_row_basic_2myisam and rpl_row_basic_3innodb fail sporadically in pushbuild
      Problem: sync_slave_with_master was missing, causing result
      mismatch.
      Fix: added sync_slave_with_master.
[28 Jul 2008 14:46] Bugs System
Pushed into 6.0.7-alpha  (revid:alik@mysql.com-20080725172155-fnc73o50e4tgl23k) (version source revid:alik@mysql.com-20080725172155-fnc73o50e4tgl23k) (pib:3)
[28 Jul 2008 19:29] Paul Dubois
Test case changes. No 6.0.x changelog entry needed.

Setting report to Patch Queued pending push of fix into 5.1.x.
[12 Aug 2008 14:55] Bugs System
Pushed into 6.0.7-alpha  (revid:sven@mysql.com-20080723143402-7w1p843x2ewm6p9m) (version source revid:davi.arnaut@sun.com-20080812141852-8e6knbqclpfd8irn) (pib:3)
[12 Aug 2008 15:20] Bugs System
Pushed into 5.1.28  (revid:sven@mysql.com-20080723143402-7w1p843x2ewm6p9m) (version source revid:davi.arnaut@sun.com-20080812142843-he05ncsggstbn57z) (pib:3)
[12 Aug 2008 17:25] Paul Dubois
Test case changes. No 5.1.x changelog entry needed.
[14 Aug 2008 2:17] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/51586

2675 He Zhenxing	2008-08-12
      Apply tomas's patch to fix rpl_row_basic.test, this can fix BUG#37884, 
      BUG#38369, enable rpl_row_basic_7ndb test
[14 Aug 2008 2:17] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/51587

2675 He Zhenxing	2008-08-12
      Apply tomas's patch to fix rpl_row_basic.test, this can fix BUG#37884, 
      BUG#38369, enable rpl_row_basic_7ndb test
[14 Aug 2008 7:17] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/51600

2677 He Zhenxing	2008-08-14 [merge]
      Merge with mysql-5.1-rpl-testfixes
[14 Aug 2008 8:20] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/51605

2685 He Zhenxing	2008-08-14 [merge]
      Merge 5.1-rpl-testfixes -> 6.0-rpl-testfixes
[15 Aug 2008 2:02] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/51688

2769 He Zhenxing	2008-08-15 [merge]
      Merge 6.0-rpl-testfixes -> 6.0
[19 Aug 2008 19:52] Bugs System
Pushed into 6.0.7-alpha  (revid:hezx@mysql.com-20080812090936-17an4ltmsgprp3ys) (version source revid:sven@mysql.com-20080818175803-c1nutd5773r6b4gd) (pib:3)
[28 Aug 2008 20:16] Bugs System
Pushed into 6.0.7-alpha  (revid:cbell@mysql.com-20080822132131-uveo6wiuecy6m2b8) (version source revid:cbell@mysql.com-20080822132131-uveo6wiuecy6m2b8) (pib:3)
[13 Sep 2008 23:19] Bugs System
Pushed into 6.0.7-alpha  (revid:sven@mysql.com-20080723143402-7w1p843x2ewm6p9m) (version source revid:john.embretsen@sun.com-20080808091208-ht48kyzsk7rim74g) (pib:3)