Bug #37431 DROP TABLE does not report errors correctly
Submitted: 16 Jun 2008 17:08 Modified: 24 Aug 2009 17:56
Reporter: Marc Alff Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.0.64 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Triage: Triaged: D4 (Minor)

[16 Jun 2008 17:08] Marc Alff
Description:
When a table is missing, DROP TABLE does not add the error in
THD::warn_list.

How to repeat:
--error ER_BAD_TABLE_ERROR
drop table no_such_table;
--> expected result, the statement failed

show warnings;
--> empty error/warning list, the error is missing.

Suggested fix:
no_warnings_for_error is set in mysql_rm_table_part2(),
and probably should not be.
[16 Jun 2008 17:39] Sveta Smirnova
Thank you for the report.

Verified as described.
[22 Aug 2009 9:42] Konstantin Osipov
Alik, this is a dup of the bug you fixed, please add a test case and close the bug.
[24 Aug 2009 17:52] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/81445

2874 Alexander Nozdrin	2009-08-24
      A test case for Bug#37431 (DROP TABLE does not report errors correctly).
[24 Aug 2009 17:56] Alexander Nozdrin
A test case has been pushed into mysql-next-bugfixing.

A bug is being closed as a duplicate of Bug#43138.
[28 Aug 2009 9:54] Bugs System
Pushed into 5.4.4-alpha (revid:alik@sun.com-20090828095047-jbux7pie1yjnwpce) (version source revid:mats@sun.com-20090826091405-64t3gq3mxbbhzwt8) (merge vers: 5.4.4-alpha) (pib:11)
[3 Nov 2009 7:16] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091102151658-j9o4wgro47m5v84d) (version source revid:alik@sun.com-20091023064702-2f8jdmny61bdl94u) (merge vers: 6.0.14-alpha) (pib:13)
[12 Nov 2009 8:18] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091110093229-0bh5hix780cyeicl) (version source revid:mikael@mysql.com-20091103113702-p61dlwc6ml6fxg18) (merge vers: 5.5.0-beta) (pib:13)