Bug #37418 Won't launch: "MySQL Workbench has encountered a problem and needs to close"
Submitted: 16 Jun 2008 2:07 Modified: 25 Feb 2009 5:16
Reporter: Ken Zo Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.0.22, 5.0.24, 5.0.25, 5.0.26, 5.0.27, 5.0.30 OS:Microsoft Windows (XP SP2 (5.1.2600))
Assigned to: CPU Architecture:Any
Tags: crash, launch, radeon, splash screen, startup

[16 Jun 2008 2:07] Ken Zo
Description:
I am unable to launch Workbench.  When I execute MySQLWorkbench.exe, I receive a window that says "MySQL Workbench has encountered a problem and needs to close.  We are sorry for the inconvenience."  When I dismiss this dialog, the process terminates with no further output.  The splash screen never displays.

I am running with full administrative privileges.  I have .NET Framework 2.0.50727.  I don't have OpenGL support.  No errors appear in the Windows Event logs.  I find no evidence of any files written by Workbench.

The same problem happened with 5.0.21 on this machine.  I tried on the same machine using a different installation of Windows XP SP2 via VMWare, and Workbench was able to launch in VMWare.

Studying usage logs generated by Sysinternals Process Monitor, about the last things that appear to be accessed prior to Microsoft's "PCHealth\ErrorReporting" things include: .NET Framework mscorwks.dll/mscorrc.dll, other .NET Framework stuff, GDIPlus stuff, and:
C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_6b128700

If there is any debugging information I can access that Workbench generates, let me know.  I can also attach portions of the Process Monitor output, if it's useful.  The error message is pretty uninformative, so it's hard for me to guess where to start looking.

How to repeat:
Launch program on my installation of Windows XP!  :)
[20 Jun 2008 18:47] Sveta Smirnova
Thank you for the report.

You said the splash screen never appears, so Workbench can not use its diagnostic GRT shell. We only can find what is wrong using operating system tools.

Please try to reinstall .NET and if problem still exists start Workbench from cmd.exe and provide us output if any.
[20 Jun 2008 19:25] Ken Zo
Reinstalling .NET (already tried previously) did not change anything.

If I run from command line, next command prompt immediately appears.  Meanwhile, Workbench churns away attempting to start up.  Finally, the error window pops up.  I.e. Workbench from the command prompt immediately returns control, so there is no opportunity for it to output anything, although the Workbench process is clearly running and doing things for a few seconds before crashing.

Is there any way to make Workbench output diagnostic information of any kind prior to the GUI being started?
[20 Jun 2008 19:52] Sveta Smirnova
Thank you for the feedback.

> Is there any way to make Workbench output diagnostic information of any kind prior to the GUI being started?

Not, there is not.

Is only way to do something here is collect as much as possible information about your operating system and machine. Like if it is 64-bit etc.
[23 Jun 2008 18:58] Ken Zo
It is not 64-bit.  Can you tell me what other specific information to provide?
[24 Jun 2008 20:49] Sveta Smirnova
Thank you for the feedback.

As we have no clue what really happened we only can guess this is problem of your OS. Please start with RAM checking. See http://oca.microsoft.com/en/windiag.asp for the program and how-to.
[24 Jul 2008 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[12 Aug 2008 22:06] Ken Zo
I just noticed that 5.0.24 fixes bug #38117, "Crash at startup screen on Radeon 7500 display adapter".  My computer has an ATI Mobility Radeon 9000 display adapter.  Workbench still won't start on this machine.  Could it be a bug related to my Radeon adapter?

I have the newest version of the display adapter driver available from my computer manufacturer (from 9/19/07).
[22 Aug 2008 18:28] Man Manman
Hi,

I've the same problem. Just today installed workbench 5.0.24 OSS and it won't even show the splash screen. I get the same error described here.
I tried to install on another PC and there it does seem to work.

This machine is a 64 bit CPU.

Ciao
Manmanman
[12 Sep 2008 11:43] Valeriy Kravchuk
All reporters:

Please, try to repeat with a newer version, 5.0.25, and inform about the results.
[12 Sep 2008 15:48] Ken Zo
Alas, the problem remains with 5.0.25.  It crashes in the exact same way.
[7 Oct 2008 18:32] Todd Williams
I have just submitted Bug #39915 which may or may not be the same error. I am observing that error on two workstations.
[14 Oct 2008 15:17] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.0.26, and inform about the results.
[15 Oct 2008 14:10] Ken Zo
The problem is unchanged in 5.0.26 OSS.
[18 Nov 2008 13:09] Miguel Solorzano
This isn't repeatable in our XP boxes, could you please try 5.0.27?. Thanks in advance.
[19 Nov 2008 0:26] Ken Zo
The problem persists in 5.0.27 OSS.
[2 Dec 2008 14:30] Miguel Solorzano
Are you verified if that crash in starup isn't a DEP issue like others reports have reported?. Thanks in advance.
[2 Dec 2008 17:28] Ken Zo
Thanks for the suggestion.  I disabled DEP entirely on my computer, and then tried again.  The problem remains unchanged, so it is not a DEP issue.
[4 Dec 2008 17:51] Susanne Ebrecht
This really seems to be related to your hardware or Windows installation. We really can't repeat it.

We are not able to do something here as long as we can't repeat it. We could bother you more longer with "please try next version". But I think it makes no sense.

I will set this bug report to "can't repeat" now. Please feel free to open it again, when you figured out more informations.
[11 Feb 2009 13:09] Dmitry Bigunyak
I got this bug on my Windows XP SP3 under VirtualBox with MySQL Workbench OSS 5.0.29
At first time after installation the tool works fine, but some time later I've started getting this bug. Maybe the problem is in some related package which was updated on host gentoo machine... Now it doesn't work and I don't know what to do.
[25 Feb 2009 5:16] Ken Zo
For what it's worth, the problem remains with my OS installation and Workbench OSS 5.0.30.  It's still the only .Net app that doesn't work on my machine. I would be happy to provide more information if there were anything in particular you had in mind.
[25 Feb 2009 8:44] Dmitry Bigunyak
The same error is in version 5.0.30 Why no one doesn't answer on our posts? This problem doesn't allow using your product at all. Turn on printing some debug information at log file if you need more information. Do something with that please, don't leave it as is.
[25 Feb 2009 9:05] Dmitry Bigunyak
I think this bug should be reopened.
[22 Apr 2009 20:52] J Fry
I have the same problem on my computer - workbench 5.0.29 and 5.0.30 will not start.  I have a Sony Vaio laptop running winxp sp3.  I have a nvidia graphics card.  I do get the splash screen but have no idea what the GRT shell diagnostic is (never used it).  I think this bug should be reopened.
[9 Jun 2009 20:54] Stephen Punak
I have the same problem with 5.0.24 and 5.0.30.

It is running in VirtualBox under Fedora 10/x64.

It worked for about a day, then quit working completely.

All other MySQL products work fine in the same XP VM (Administrator, Query Browser etc)
[10 Jun 2009 6:42] Dmitry Bigunyak
Guys, try to use version 5.1.12, it works for me.
[15 Aug 2010 13:45] Bo Pa
Same issue with v.5.2.26 
Works fine with v.5.1.18
[25 Aug 2010 21:31] Andy Jewell
I get the same behavior using 5.2.26.  The unusual thing is that after I first installed, I was able to use it successfully.  In fact, I created a model, exported it, created a db, run sql scripts, etc.  AWESOME software!  Anyhow, a technician came in an swapped out my keyboard while I was at lunch.  The keyboard didn't work so I had no way of doing a managed restart so I had to forcefully power down.  It hasn't worked at all since then (citing the same "... has encountered..." message as above).  

* Tried uninstalling and reinstalling to no effect.

I have *some type* of administrator rights on this machine since I can install software.  However, certain menus are missing or changed so apparently this is our IT departments "safe administrator" configuration.

OS: Version	5.1.2600 Service Pack 3 Build 2600
Graphics: NVIDIA NVS 3100M
Graphics Installed Drivers	nv4_disp.dll
Graphics Driver Version	6.14.11.8918

I will try to install the previous 5.1.18 version as recommended but it's disappointing since the model file will be incompatible.
[25 Aug 2010 21:47] Andy Jewell
Version 5.1.18a does work for me, as well.  Thanks for the suggestion!
[25 Aug 2010 22:11] Andy Jewell
For what it's worth - after using 5.1.18a, I downloaded the 5.2.26 ZIP file (not the installer) and unzipped INTO the 5.1.18a folder (did not uninstall prior to doing this).  When I came back in, 5.2.26 started!  I'm working it now but I don't know for sure if this will work for the long term.
[16 Oct 2010 19:27] Toms Kovkajevs
I'm did have this problem in my Windows XP on VidtualBox! Did some "clicks" in display configuration section and everything started to work!
[13 Apr 2011 18:10] Emery Fabrice NZEYIMANA
I had the almost same problem with 5.2.33: (just a beep and nothing shown, nothing in error log. After installing .NET 4, the problem seems solved. 
WB 5.1 used to run fine (without .NET 4) and the problem surfaced when I upgraded to 5.2 

Win XP SP3 
Works fine on Win7 (with .NET 4)
[21 May 2013 8:08] Soumya Banerjee
Just wanted to post my findings if at all that helps anyone experiencing this issue.
I have non-install (zip) version of MySQL 5.2.39 running on Windows XP SP3 inside VirtualBox 4.2.12. I was getting the very same error upon trying to run MySQLWorkbench.exe. I did have .NET versions 2.0 to 4.0 installed on my system.

While I was clueless, my attention turned to python executable (python.exe) in the installation folder. Guess what happened, when I tried running it. It said it couldn't find msvcrt100.dll. Source of error was clear (at least for me). All I did  - installed Microsoft VC Runtime 2010 SP1 x86[http://www.microsoft.com/en-us/download/details.aspx?id=8328]. 

Voila! MySQL Workbench now works....
[18 Mar 2014 19:22] Michael Colton
My laptop has both an Intel graphics chip and an Nvidia chip. I have my computer set to use the Nvidia by default. With that set, MySQL Workbench (6.0.9.11421 build 1170) won't open, won't show an error. Nothing. It shows up in the task manager for a minute then disapears.

If I switch to run from the Intel chip, it runs without any issues.

I had tried uninstalling old versions, and deleting the AppData folders without success.

This is on Win7 64bit