Bug #37248 Some 'Big' tests failing on 6.0
Submitted: 6 Jun 2008 15:10 Modified: 15 Oct 2012 14:05
Reporter: Patrick Crews Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:6.0 OS:Any
Assigned to: CPU Architecture:Any
Tags: big-test, disabled, mysql-test-run, Tests
Triage: D3 (Medium)

[6 Jun 2008 15:10] Patrick Crews
Description:
The following 'big' tests are failing in the 6.0 test suite:
main.alter_table-big 
main.create-big 
main.merge-big 
main.variables-big

It appears that alter_table and create are failing for a similar root cause:
'master-bin.000001' from 106' failed: 1220: Error when executing command SHOW BINLOG EVENTS: Wrong offset or I/O error

merge and variables seem to be failing for other reasons (5.1 -> 6.0 changes, tests that need repair, etc).

How to repeat:
In a 6.0 tree, execute the following commands from the mysql-test directory

./mysql-test-run --force --do-test big
You can expect to see the previously listed 4 errors.

Suggested fix:
Determine whether this is an actual server issue, a legitimate change that requires a test update, or a broken test (uncommented lines, etc).

It would seem that the --big-test options should be run prior to checking in code so that test-breaking changes can be caught and dealt with earlier.  (As indicated in Bug #32052 (Verified): Small inconsistency with the big_test and ndb_extra test options)
[25 Jun 2008 7:49] Michael Widenius
note:

main.variables-big is fixed in maria tree and will be merged to 6.0 shortly
[25 Jun 2008 15:34] Michael Widenius
Before fixing things in 6.0, first fix the problems in 5.1 reported in Bug#37635
[21 Dec 2009 9:48] Konstantin Osipov
create-big.test and alter_table-big.test are out of date.
They rely on debug sleeps that are no longer present in the 
code. Since the sleeps are long gone, fixing the problem doesn't 
involve just updating the result file or using macro 
"show_binlog_events2.inc" instead of "show binlog events" 
statement. The tests need to be rewritten using debug sync 
points, and results then need to be updated.
[21 Dec 2009 9:48] Konstantin Osipov
Partial fix attached.
[21 Dec 2009 9:49] Konstantin Osipov
A partial patch for create-big and alter_table-big tests.

Attachment: cb.diff (text/x-diff), 5.10 KiB.

[15 Oct 2012 14:05] Erlend Dahl
Fixed in 5.5.20