Bug #36973 backup_tablespace.test fails in pushbuild
Submitted: 26 May 2008 14:51 Modified: 29 Sep 2008 17:38
Reporter: Ingo Strüwing Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Backup Severity:S3 (Non-critical)
Version:6.0-engines-merge OS:Any
Assigned to: Jørgen Løland CPU Architecture:Any
Triage: D3 (Medium)

[26 May 2008 14:51] Ingo Strüwing
Description:
Seen on win2003-x86 in 6.0-engines-merge:

main.backup_tablespace         [ fail ]

mysqltest: At line 35: query 'CREATE TABLE backup_ts.not_ts (id int, comment char(40)) ENGINE=FALCON' failed: 1005: Can't create table 'backup_ts.not_ts' (errno: 156)

The result from queries just before the failure was:
DROP TABLE IF EXISTS backup_ts.not_ts;
DROP TABLE IF EXISTS backup_ts.has_ts;
DROP DATABASE IF EXISTS backup_ts;
CREATE DATABASE backup_ts;
Test 1:
Create a tablespace.
CREATE TABLESPACE bup_ts ADD DATAFILE 'bup_ts.dat' COMMENT = 'test tablespace backup' ENGINE=FALCON;
Create tables and add data.
CREATE TABLE backup_ts.not_ts (id int, comment char(40)) ENGINE=FALCON;

More results from queries before failure can be found in e:\pb\mysql-6.0-engines-merge\1\mysql-6.0.6-alpha-pb1\mysql-test\var-ps_stm-6\log\backup_tablespace.log

I will disable the test case for now. Please re-enable after fix.

How to repeat:
See pushbuild.
[27 Jun 2008 19:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/48673

2663 Konstantin Osipov	2008-06-27
      Disable backup_tablespace.test (Bug#36973)
[21 Aug 2008 13:56] Jørgen Løland
Setting state open since the patch just disabled the test
[25 Aug 2008 7:10] Jørgen Løland
Could not reproduce on linux or windows machine. Test has been re-enabled to see if it still fails in pb.
[1 Sep 2008 6:50] Jørgen Løland
Test enabled, and does not fail in pushbuild.
[28 Sep 2008 19:20] Øystein Grøvlen
Pushed to 6.0 main for 6.0.8
[29 Sep 2008 17:38] Paul Dubois
Nothing done that I can see. No changelog entry needed.