Bug #36646 "make install" from BK sources fails to install test files
Submitted: 10 May 2008 17:06 Modified: 15 Jul 2008 21:11
Reporter: Paul Dubois Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.0+, 5.1, 6.0 BK OS:Any
Assigned to: Timothy Smith CPU Architecture:Any
Triage: D2 (Serious)

[10 May 2008 17:06] Paul Dubois
Description:
I compile MySQL use the BK source tree.

There is a filename pattern that is not specific enough in one of the "make install" commands, and it causes the operation to try to install the SCCS directory.

Example output for 5.0:

...
/usr/bin/install -c -m 644 ./t/*.opt /var/mysql/50062/mysql-test/t
/usr/bin/install -c ./t/*.sh /var/mysql/50062/mysql-test/t
/usr/bin/install -c -m 644 ./t/*.slave-mi /var/mysql/50062/mysql-test/t
/usr/bin/install -c -m 644 ./r/*.result /var/mysql/50062/mysql-test/r
/usr/bin/install -c -m 644 ./r/*.require /var/mysql/50062/mysql-test/r
/usr/bin/install -c -m 644 ./include/*.inc /var/mysql/50062/mysql-test/include
/usr/bin/install -c -m 644 ./include/*.test /var/mysql/50062/mysql-test/include
/usr/bin/install -c -m 644 ./std_data/*.dat /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.*001 /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.cnf /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/des_key_file /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/Moscow_leap /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/Index.xml /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.pem /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.frm /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.MY* /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.cnf /var/mysql/50062/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/ndb_backup50_data_be/BACKUP* /var/mysql/50062/mysql-test/std_data/ndb_backup50_data_be
/usr/bin/install -c -m 644 ./std_data/ndb_backup50_data_le/BACKUP* /var/mysql/50062/mysql-test/std_data/ndb_backup50_data_le
/usr/bin/install -c -m 644 ./std_data/funcs_1/* /var/mysql/50062/mysql-test/std_data/funcs_1
/usr/bin/install: omitting directory `./std_data/funcs_1/SCCS'
make[4]: *** [install-data-local] Error 1
make[4]: Leaving directory `/src/extern/MySQL/bk/mysql-5.0/mysql-test'
make[3]: *** [install-am] Error 2
make[3]: Leaving directory `/src/extern/MySQL/bk/mysql-5.0/mysql-test'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/src/extern/MySQL/bk/mysql-5.0/mysql-test'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/src/extern/MySQL/bk/mysql-5.0'
make: *** [install] Error 2

Example output for 5.1:

...
/usr/bin/install -c -m 644 ./include/*.inc /var/mysql/50125/mysql-test/include
/usr/bin/install -c -m 644 ./include/*.sql /var/mysql/50125/mysql-test/include
/usr/bin/install -c -m 644 ./include/*.test /var/mysql/50125/mysql-test/include
/usr/bin/install -c -m 644 ./std_data/*.dat /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.*001 /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.cnf /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/des_key_file /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/Moscow_leap /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/Index.xml /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.pem /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.frm /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.MY* /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.cnf /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/*.txt /var/mysql/50125/mysql-test/std_data
/usr/bin/install -c -m 644 ./std_data/ndb_backup50/BACKUP* /var/mysql/50125/mysql-test/std_data/ndb_backup50
/usr/bin/install -c -m 644 ./std_data/ndb_backup51/BACKUP* /var/mysql/50125/mysql-test/std_data/ndb_backup51
/usr/bin/install -c -m 644 ./std_data/ndb_backup51_data_be/BACKUP* /var/mysql/50125/mysql-test/std_data/ndb_backup51_data_be
/usr/bin/install -c -m 644 ./std_data/ndb_backup51_data_le/BACKUP* /var/mysql/50125/mysql-test/std_data/ndb_backup51_data_le
/usr/bin/install -c -m 644 ./std_data/parts/part_* /var/mysql/50125/mysql-test/std_data/parts
/usr/bin/install -c -m 644 ./std_data/funcs_1/* /var/mysql/50125/mysql-test/std_data/funcs_1
/usr/bin/install: omitting directory `./std_data/funcs_1/SCCS'
make[3]: *** [install-data-local] Error 1
make[3]: Leaving directory `/src/extern/MySQL/bk/mysql-5.1/mysql-test'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/src/extern/MySQL/bk/mysql-5.1/mysql-test'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/src/extern/MySQL/bk/mysql-5.1/mysql-test'
make: *** [install-recursive] Error 1

How to repeat:
See above.
[10 May 2008 20:15] Miguel Solorzano
Thank you for the bug report.
[11 May 2008 1:12] Miguel Solorzano
Bug http://bugs.mysql.com/bug.php?id=24402 has been marked as duplicate of this
one.
[12 May 2008 15:14] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=36665 has been marked as duplicate of this one with a different test case.
[12 May 2008 22:00] Sveta Smirnova
Bug #36560 was marked as duplicate of this one.
[15 May 2008 14:21] Timothy Smith
Already fixed in -build team tree.

Not present in any released mysql version, no need to document it.
[13 Jul 2008 13:27] Sveta Smirnova
Reopened as bug still exists in 5.1.25 package. See bug #38059 also. Or probably all these ndb_config* bugs (38095, 24402, 36560) are not duplicates of this one?
[15 Jul 2008 20:58] Timothy Smith
This bug has nothing to do with Cluster.  The other bugs should not have been flagged as Duplicates of this one.

I tried to repeat bug #38059 and could not; I added a comment on that bug.  I have closed bug #35650 as "Can't Repeat" for similar reasons.  I've re-opened bug #24402, as I can't reproduce it with 5.1.26-rc source nor with 5.0.51b.  I recommend that it be reverified, or closed as "Can't repeat".
[15 Jul 2008 21:11] Timothy Smith
Re-closing, other bugs which had been incorrectly flagged as duplicates of this bug are now Open requiring further attention.