Bug #36394 Server update installer 'unattended' fails when param '--backupdir ...' not givn
Submitted: 29 Apr 2008 11:24 Modified: 31 Jul 2008 16:41
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version: OS:Linux
Assigned to: BitRock Merlin CPU Architecture:Any

[29 Apr 2008 11:24] Carsten Segieth
The unattended server update installer fails when --installdir is not the default and when '--backupdir' was not given on the command line with this problem:

/nfstmp2/merlin/packages/ --mode unattended --installdir /data0/merlin/monitoring/
There has been an error.
Error renaming /data0/merlin/monitoring/ to /home/qauser/mysql/enterprise/monitor/backup/apache-tomcat

I tried to update a installation which was *not* installed to the default path (see command line above).

Not yet tested on other platforms, but I assume the problem exists also on other systems, like the already solved very similar agent problem bug #31026.

How to repeat:
see above

Suggested fix:
- make update installer working also in unattended mode
[29 Apr 2008 11:26] Carsten Segieth
Work around:
Please set the "--backupdir <...>" comand line option.
[8 May 2008 15:15] BitRock Merlin
Patch sent to Keith.
[15 May 2008 2:11] Keith Russell
Installed in versions =>
[29 Jul 2008 16:23] Carsten Segieth
checked OK with
[31 Jul 2008 16:41] Tony Bedford
An entry was added to the 1.3.3 changelog:

The unattended server update installer failed when --installdir was not the default and when --backupdir was not given on the command line.