Bug #34654 RESET SLAVE and START SLAVE does not clear Last_IO_Errno
Submitted: 19 Feb 2008 5:04 Modified: 16 May 2009 9:10
Reporter: Johan Andersson Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.1 OS:Any
Assigned to: Andrei Elkin CPU Architecture:Any
Tags: replication, RESET SLAVE, show slave status, start slave, stop slave
Triage: Triaged: D2 (Serious)

[19 Feb 2008 5:04] Johan Andersson
Description:
RESET SLAVE; and STOP SLAVE; does not clear Last_IO_Errno and Last_IO_Error (the same also applies for Last_SQL_Errno and Last_SQL_Error):

               Slave_IO_State: Waiting for master to send event
                   Last_Errno: 0
                   Last_Error: 
                 Skip_Counter: 0
        Seconds_Behind_Master: 0
...
                Last_IO_Errno: 2013
                Last_IO_Error: error reconnecting to master 'rep@r2mys-front41:3306' - retry-time: 60  retries: 86400
               Last_SQL_Errno: 0
               Last_SQL_Error: 

stop slave; start slave; show slave status \G;

               Slave_IO_State: Waiting for master to send event
-..
             Slave_IO_Running: Yes
            Slave_SQL_Running: Yes
 ...
       Seconds_Behind_Master: 0
                Last_IO_Errno: 2013
                Last_IO_Error: error reconnecting to master 'rep@r2mys-front41:3306' - retry-time: 60  retries: 86400
               Last_SQL_Errno: 0
               Last_SQL_Error: 

How to repeat:
see above:

Have by replication running.
kill master
restart master

show slave status\G
stop slave; 
start slave;
show slave status\G

Suggested fix:
clear errors if it is no longer a problem
[20 Feb 2008 19:29] Sveta Smirnova
Thank you for the report.

With STOP SLAVE this is not a bug: last error since slave started displayed. RESET SLAVE clears error number and message. So I close the report as "Can't repeat"
[20 Feb 2008 19:45] Johan Andersson
Interesting.. what version exactly did you use?

br
johan
[20 Feb 2008 20:40] Sveta Smirnova
Latest 5.0, 5.1 and 6.0 BK sources.
[6 Mar 2008 14:44] Andrei Elkin
Susanne, it looks similar to Bug #34492  RESET SLAVE does not reset last_error.
[14 Mar 2008 14:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/44005

ChangeSet@1.2579, 2008-03-14 15:42:27+01:00, msvensson@pilot.mysql.com +2 -0
  Mask columns 35 and 36 since Last_IO_errno is not reset du to 
  bug#34654
[14 Mar 2008 20:02] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/44040

ChangeSet@1.2582, 2008-03-14 21:02:52+01:00, msvensson@pilot.mysql.com +3 -0
  Bug #34654  	RESET SLAVE and STOP SLAVE/START SLAVE does not clear Last_XYZ_Errno
[14 Mar 2008 20:05] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/44042

ChangeSet@1.2583, 2008-03-14 21:06:01+01:00, msvensson@pilot.mysql.com +2 -0
  Bug#34654 RESET SLAVE and STOP SLAVE/START SLAVE does not clear Last_XYZ_Errno
[1 May 2008 11:33] Andrei Elkin
Making this one as the parent bugs for others because here has been already some work done.
[1 May 2008 11:35] Andrei Elkin
know childs: Bug #31393, Bug #34492.
[1 May 2008 13:27] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/46260

ChangeSet@1.2646, 2008-05-01 16:26:05+03:00, aelkin@mysql1000.dsl.inet.fi +5 -0
  Bug #34654 RESET SLAVE and START SLAVE does not clear Last_IO_Errno
  
  There were no resetting of the io thread's error status at reset_slave() and 
  at the beginning of handle_slave_io() that corresponds to start slave.
  
  Fixed with deploying clean-up at necessary places of the code.
[8 May 2008 17:06] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/46525

ChangeSet@1.2646, 2008-05-08 20:05:25+03:00, aelkin@mysql1000.dsl.inet.fi +5 -0
  Bug #34654 RESET SLAVE and START SLAVE does not clear Last_IO_Errno
  
  There were no resetting of the io thread's error status at reset_slave() and 
  at the beginning of handle_slave_io() that corresponds to start slave.
  
  Fixed with deploying clean-up at necessary places of the code.
[7 Jun 2008 9:39] Andrei Elkin
Pushed to the bzr 6.0-rpl.
[30 Jan 2009 13:26] Bugs System
Pushed into 6.0.10-alpha (revid:luis.soares@sun.com-20090129165607-wiskabxm948yx463) (version source revid:luis.soares@sun.com-20090129163120-e2ntks4wgpqde6zt) (merge vers: 6.0.10-alpha) (pib:6)
[30 Jan 2009 15:07] Bugs System
Pushed into 5.1.32 (revid:luis.soares@sun.com-20090129165946-d6jnnfqfokuzr09y) (version source revid:sp1r-msvensson@pilot.mysql.com-20080325174049-18586) (merge vers: 5.1.24-rc) (pib:6)
[1 Feb 2009 18:16] Jon Stephens
Documented bugfix in the 5.1.32 and 6.0.10 changelogs as follows:

        RESET MASTER and RESET SLAVE now reset the values
        shown for Last_IO_Error, Last_IO_Errno, Last_SQL_Error, 
        and Last_SQL_Errno in the output of SHOW SLAVE STATUS.

Also noted this change in the descriptions of these columns given in the SHOW SLAVE STATUS Syntax section of the 5.1 and 6.0 version of the Manual.
[17 Feb 2009 14:52] Bugs System
Pushed into 5.1.32-ndb-6.3.23 (revid:tomas.ulin@sun.com-20090217131017-6u8qz1edkjfiobef) (version source revid:tomas.ulin@sun.com-20090203133556-9rclp06ol19bmzs4) (merge vers: 5.1.32-ndb-6.3.22) (pib:6)
[17 Feb 2009 16:40] Bugs System
Pushed into 5.1.32-ndb-6.4.3 (revid:tomas.ulin@sun.com-20090217134419-5ha6xg4dpedrbmau) (version source revid:tomas.ulin@sun.com-20090203133556-9rclp06ol19bmzs4) (merge vers: 5.1.32-ndb-6.3.22) (pib:6)
[17 Feb 2009 18:16] Bugs System
Pushed into 5.1.32-ndb-6.2.17 (revid:tomas.ulin@sun.com-20090217134216-5699eq74ws4oxa0j) (version source revid:tomas.ulin@sun.com-20090201210519-vehobc4sy3g9s38e) (merge vers: 5.1.32-ndb-6.2.17) (pib:6)
[22 Apr 2009 20:46] Ben Krug
*Was* this fix really pushed?  I see kyle observed it in 5.1.33, and I downloaded 5.1.32 (mysql-5.1.32-linux-i686-icc-glibc23.tar.gz) and found the bug still in 5.1.32, although the bug report says the fix was pushed into 5.1.32.
[6 May 2009 11:12] Jon Stephens
Andrei, can you verify whether or not this fix appeared in 5.1? If not, I'll remove the changelog entry, etc.

Thanks!
[14 May 2009 20:08] Andrei Elkin
Jon,
Bug #34654 fixes were pushed only to 6.0 and backported into telco
branches. Confirming, 5.1 does not have the fixes.

cheers,

Andrei
[15 May 2009 10:02] Jon Stephens
Thanks for the info. I'll correct the changelog and other docs ASAP.
[16 May 2009 9:10] Jon Stephens
Amended changelog entry and SHOW SLAVE STATUS description to show that fix was applied in NDB-6.2.17/6.3.23/6.4.3 (but not in 5.1-main). Closed.
[3 Dec 2009 13:49] Jon Stephens
Also documented in the 5.6.0 changelog. See BUG#48463.
[7 Mar 2010 1:49] Paul Dubois
Moved 5.6.0 changelog entry to 5.5.3.