Bug #34532 Some funcs_1 tests do not clean up at end of testing
Submitted: 13 Feb 2008 18:11 Modified: 28 Mar 2008 19:26
Reporter: Matthias Leich Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.0 OS:Any
Assigned to: Matthias Leich CPU Architecture:Any
Triage: D3 (Medium)

[13 Feb 2008 18:11] Matthias Leich
Description:
Please run for example
./mysql-test-run.pl --suite=funcs_1 --check-testcases \
     myisam_storedproc_02

mysql-test-run.pl reports that the value of
max_heap_table_size was changed.

Other examples:
A lot of tests source some files which create tables
and load content but do not remove these tables at end.

How to repeat:
See above
[13 Feb 2008 18:27] Matthias Leich
D4 because it is a minor failure.
- fair probability that it affects a developer during
  maintenance of funcs_1 tests (wastes working time)
- failure because these tests are similar used (pushbuild)
  like regression tests and it is therefore expected that
  these tests have a similar architecture
I5 because customers are not affected and developers see
  these issues only if they have to modify these tests

This bug harms
WL#4203 Reorganize and fix the data dictionary tests of 
        testsuite funcs_1
[13 Feb 2008 20:15] Matthias Leich
The bug fix will be done in
WL#4203 Reorganize and fix the data dictionary tests of 
        testsuite funcs_1
[25 Feb 2008 21:08] Matthias Leich
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/42956

ChangeSet@1.2584, 2008-02-25 21:52:13+01:00, mleich@five.local.lan +197 -0
  WL#4203 Reorganize and fix the data dictionary tests of
          testsuite funcs_1
  1. Fix the following bugs
     Bug#30440 "datadict" tests (all engines) fail:
               Character sets depend on configuration
        Solution: Test variants charset_collation_* adjusted to
                  different builds
     Bug#32603 "datadict" tests (all engines) fail in "community" tree:
               "PROFILING" table
        Solution: Excluding "PROFILING" table from queries
     Bug#33654 "slow log" is missing a line
        Solution: Unify the content of the fields TABLES.TABLE_ROWS and
                  STATISTICS.CARDINALITY within result sets
     Bug#34532 Some funcs_1 tests do not clean up at end of testing
        Solution: DROP objects/reset global server variables modified
                  during testing + let tests missing implementation end
                  before loading of tables
     Bug#31421 funcs_1: ndb__datadict fails, discrepancy between scripts
               and expected results
        Solution: Cut <engine>__datadict tests into smaller tests 
                  + generate new results.
     Bug#33599 INFORMATION_SCHEMA.STATISTICS got a new column INDEX_COMMENT:
               tests fail (2)
        Generation of new results during post merge fix
     Bug#33600 CHARACTER_OCTET_LENGTH is now CHARACTER_MAXIMUM_LENGTH * 4
        Generation of new results during post merge fix
     Bug#33631 Platform-specific replace of CHARACTER_MAXIMUM_LENGTH 
               broken by 4-byte encoding
        Generation of new results during post merge fix
        + removal of platform-specific replace routine (no more needed)
  2. Restructure the tests
     - Test not more than one INFORMATION_SCHEMA view per testscript
     - Separate tests of I_S view layout+functionality from content
       related to the all time existing databases 
       "information_schema", "mysql" and "test"
     - Avoid storage engine related variants of tests which are not 
       sensible to storage engines at all.
  3. Reimplement or add some subtests + cleanup
  There is a significant probability that even the reviewed changeset 
  - does not fix all bugs from above   or
  - contains new bugs which show up on some platforms <> Linux or on
    one of the various build types
[11 Mar 2008 13:06] Matthias Leich
WL#4203 Reorganize and fix the data dictionary tests of
        testsuite funcs_1
was pushed to mysql-<version>-build
Version is in (5.0,5.1,6.0).

I fixed at least all issues in version 5.0 and
version 6.0 (during upmerge).
But I forgot to fix some of the issues in NDB testcases
within MySQL 5.1.
Therefore the bug is not complete fixed and I set it back
in progress.
[12 Mar 2008 0:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/43790

ChangeSet@1.2583, 2008-03-11 19:54:35+01:00, mleich@five.local.lan +36 -0
  Post fix for
  WL#4203 Reorganize and fix the data dictionary tests of
          testsuite funcs_1
  because the goal to fix
  Bug#34532 Some funcs_1 tests do not clean up at end of testing
  was partially missed.
  Some minor additional modifications are for
     WL#4304 Cleanup in funcs_1 tests
[12 Mar 2008 0:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/43791

ChangeSet@1.2583, 2008-03-11 19:49:50+01:00, mleich@five.local.lan +21 -0
  Post fix for
  WL#4203 Reorganize and fix the data dictionary tests of
          testsuite funcs_1
  because the goal to fix
  Bug#34532 Some funcs_1 tests do not clean up at end of testing
  was partially missed.
  Some minor additional modifications are for
     WL#4304 Cleanup in funcs_1 tests
[12 Mar 2008 11:56] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/43824

ChangeSet@1.2566, 2008-03-12 12:56:07+01:00, mleich@five.local.lan +31 -0
  Post merge fix for
[12 Mar 2008 15:57] Matthias Leich
Fixes pushed to mysql-<version>-build
Version is in (5.0,5.1,6.0).
[27 Mar 2008 22:03] Bugs System
Pushed into 5.1.24-rc
[27 Mar 2008 22:11] Bugs System
Pushed into 5.0.60
[28 Mar 2008 11:10] Bugs System
Pushed into 6.0.5-alpha
[28 Mar 2008 19:26] Paul Dubois
Fix involves test case changes. No changelog entry needed.