Bug #34291 compile-amd64-debug-max-no-ndb missing
Submitted: 4 Feb 2008 17:49 Modified: 14 May 2008 2:19
Reporter: Susanne Ebrecht Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:6.0.3-alpha, 5.1.22-rc, 5.0.51a OS:Any (AMD 64)
Assigned to: Joerg Bruehe CPU Architecture:Any
Triage: D4 (Minor) / R1 (None/Negligible) / E1 (None/Negligible)

[4 Feb 2008 17:49] Susanne Ebrecht
Description:
Release tree:

$ ls BUILD/
compile-amd64-debug-max
compile-amd64-max
compile-amd64-max-sci

bk tree:
compile-amd64-debug-max
compile-amd64-debug-max-no-ndb
compile-amd64-gcov

compile-amd64-debug-max-no-ndb is missing in all released versions.

How to repeat:
Look into the BUILD directory

Suggested fix:
Add it from bk tree
[4 Feb 2008 18:08] Hartmut Holzgraefe
The EXTRA_DIST list in BUILD/Makefile.am is missing several of the later added BUILD/compile-... files. When regenerating the file list from sorted "ls" output the diff is as follows:

===== Makefile.am 1.14 vs edited =====
--- 1.14/BUILD/Makefile.am      2008-02-04 19:05:18 +01:00
+++ edited/Makefile.am  2008-02-04 19:03:37 +01:00
@@ -27,14 +27,29 @@
                        compile-alpha-cxx \
                        compile-alpha-debug \
                        compile-amd64-debug-max \
+                       compile-amd64-debug-max-no-ndb \
+                       compile-amd64-gcov \
+                       compile-amd64-gprof \
                        compile-amd64-max \
                        compile-amd64-max-sci \
+                       compile-amd64-noopt \
+                       compile-amd64-valgrind-max \
                        compile-darwin-mwcc \
                        compile-dist \
                        compile-hpux11-parisc2-aCC \
                        compile-ia64-debug-max \
                        compile-irix-mips64-mipspro \
+                       compile-ndb-autotest \
                        compile-pentium \
+                       compile-pentium64 \
+                       compile-pentium64-debug \
+                       compile-pentium64-debug-max \
+                       compile-pentium64-gcov \
+                       compile-pentium64-gprof \
+                       compile-pentium64-max \
+                       compile-pentium64-max-sci \
+                       compile-pentium64-valgrind-max \
+                       compile-pentium-cybozu \
                        compile-pentium-debug \
                        compile-pentium-debug-max \
                        compile-pentium-debug-max-no-embedded \
@@ -51,15 +66,12 @@
                        compile-pentium-mysqlfs-debug \
                        compile-pentium-pgcc \
                        compile-pentium-valgrind-max \
-                       compile-pentium64-debug \
-                       compile-pentium64-debug-max \
-                       compile-pentium64-max-sci \
-                       compile-pentium64-valgrind-max \
                        compile-ppc \
                        compile-ppc-debug \
                        compile-ppc-debug-max \
                        compile-ppc-debug-max-no-ndb \
                        compile-ppc-max \
+                       compile-solaris-amd64 \
                        compile-solaris-sparc \
                        compile-solaris-sparc-debug \
                        compile-solaris-sparc-forte \
[4 Feb 2008 18:20] Joerg Bruehe
These scripts are unsupported,
especially they are not used in release builds.

So unless some developer(s) use(s) them and then maintain(s) them,
all MySQL AB can do is provide them "as is".

Why is it considered "unacceptable" to maintain a scriptlet consisting of "configure ; make" with the options preferred by the individual user ?
[4 Feb 2008 19:49] Jonas Oreland
my vote is "not a bug"
[15 Apr 2008 14:17] Joerg Bruehe
I will check that all files "BUILD/compile-*" that exist
also make it into a source tarball, from 5.0 up.

This does *not* imply any responsibility for their contents,
or include any maintenance responsibilities.

Docs team:
*If* you have a section in the manual about this,
or if you document this as a bug fix when it eventually gets pushed,
please describe these files as being provided on an "as-is" base.
There is nobody who will align these files with changing configurations,
added/modified/removed features, etc,
(unless a developer uses them for his/her own purposes and fixes problems s/he notes).
[17 Apr 2008 16:42] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/45561

ChangeSet@1.2610, 2008-04-17 18:41:23+02:00, joerg@trift2. +1 -0
  Fix for   Bug #34291  compile-amd64-debug-max-no-ndb missing
      
  Include several "BUILD/compile-*" files in a source tarball ("make dist" target)
  which might be useful to community users who want to build from source.
  
  When merging this up, the "BUILD/compile-*" file list needs to be checked.
[18 Apr 2008 10:07] Joerg Bruehe
I checked the patch locally ("make dist"), got the desired effect.
[18 Apr 2008 15:01] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/45609

ChangeSet@1.2564, 2008-04-18 16:58:47+02:00, joerg@trift2. +1 -0
  BUILD/Makefile.am
      Post-merge fix:  Add those files which are new in version 5.1
  
  This is the 5.1 version of the fix for
     Bug #34291  compile-amd64-debug-max-no-ndb missing
[18 Apr 2008 16:25] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/45617

ChangeSet@1.2642, 2008-04-18 18:24:00+02:00, joerg@trift2. +1 -0
  BUILD/Makefile.am
      Add those files which are added in 6.0
  
  Fix for    Bug #34291  compile-amd64-debug-max-no-ndb missing
[18 Apr 2008 17:57] Joerg Bruehe
Patch is available in the build team trees from 5.0 up to 6.0
[1 May 2008 10:05] Bugs System
Pushed into 5.1.25-rc
[1 May 2008 10:07] Bugs System
Pushed into 6.0.6-alpha
[1 May 2008 19:13] Bugs System
Pushed into 5.0.62
[14 May 2008 2:19] Paul Dubois
Noted in 5.0.62, 5.1.25, 6.0.6 changelogs.

Several additional configuration scripts in the BUILD directory now
are included in source distributions. These may be useful for users
who wish to build MySQL from source.