Bug #34108 "Drop function" (test "storedproc_06") returns different message (all handlers)
Submitted: 28 Jan 2008 16:50 Modified: 14 May 2008 15:51
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Engine Severity:S3 (Non-critical)
Version:5.1.23-rc OS:Any
Assigned to: Davi Arnaut CPU Architecture:Any
Triage: D3 (Medium)

[28 Jan 2008 16:50] Joerg Bruehe
Description:
In the current 5.1.23-rc build, all "storedproc_06" tests
(innodb_storedproc_06, memory_storedproc_06, myisam_storedproc_06, ndb_storedproc_06)
fail with a symptom like this:

::::::::::::::
funcs_1.innodb_storedproc_06   [ fail ]

--- /PATH/mysql-test/suite/funcs_1/r/innodb_storedproc_06.result
+++ /PATH/mysql-test/suite/funcs_1/r/innodb_storedproc_06.reject
@@ -125,10 +125,7 @@
 drop user 'user_1'@'localhost';
 DROP PROCEDURE sp3;
 DROP FUNCTION fn1;
-Warnings:
-Error  1133    Can't find any matching row in the user table
-Error  1269    Can't revoke all privileges for one or more of the requested users
-Warning        1405    Failed to revoke all privileges to dropped routine
+ERROR 42000: Can't find any matching row in the user table

 Testcase 3.1.6.4:
 -----------------

mysqltest: Result content mismatch
::::::::::::::

Note that this is the same place in the test for which bug#33464 was reported, but I did *not* see the crash reported there.

How to repeat:
Run the "funcs_1" suite.
[2 May 2008 20:09] Matthias Leich
IMHO
- neither the old expected nor the new results of this
  test can be correct
- a statement sequence of
  1. 'user_1'@'localhost':  Create PROCEDURE sp3
  2. 'user_1'@'localhost':  Create FUNCTION fn1
  3. Root: drop user 'user_1'@'localhost';
  4. Root: DROP PROCEDURE sp3;
  5. DROP FUNCTION fn1;
  must not end with Warnings like
  Warning 1403 There is no such grant defined 
               for user 'user_1' on host 'localhost'
               on routine 'fn1'
[6 May 2008 14:47] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/46394

ChangeSet@1.2609, 2008-05-06 11:46:43-03:00, davi@mysql.com +5 -0
  Bug#34108 "Drop function" (test "storedproc_06") returns different message (all handlers)
  
  The problem is that the patch for Bug 33464 didn't update the
  results of the test cases which caused the problem.
  
  Dropping a stored routine also revoke privileges for all users
  on the stored routine and errors about missing grants are converted
  into warnings. Before Bug 33464 such errors could be incorrectly
  returned to the user, which would later trigger a assertion due to
  multiple errors being set.
[6 May 2008 18:43] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/46422

ChangeSet@1.2609, 2008-05-06 15:43:13-03:00, davi@mysql.com +6 -0
  Bug#34108 "Drop function" (test "storedproc_06") returns different message (all handlers)
  
  The problem is that the patch for Bug 33464 didn't update the
  results of the test cases which caused the problem.
  
  Dropping a stored routine also revoke privileges for all users
  on the stored routine and errors about missing grants are converted
  into warnings. Before Bug 33464 such errors could be incorrectly
  returned to the user, which would later trigger a assertion due to
  multiple errors being set.
[6 May 2008 20:10] Davi Arnaut
Queued to 5.1-bugteam
[14 May 2008 15:21] Bugs System
Pushed into 5.1.25-rc
[14 May 2008 15:51] Paul Dubois
Test suite change. No changelog entry needed.
[22 May 2008 9:49] Bugs System
Pushed into 6.0.6-alpha