Bug #33691 Falcon crash on partition manipulations
Submitted: 4 Jan 2008 13:41 Modified: 5 Mar 2008 14:49
Reporter: Philip Stoev Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Partitions Severity:S3 (Non-critical)
Version:6.0.4-p2 OS:Any
Assigned to: Mattias Jonsson CPU Architecture:Any
Triage: D1 (Critical) / R2 (Low) / E3 (Medium)

[4 Jan 2008 13:41] Philip Stoev
Description:
The iuds3_xddl test combines concurrent insert/update/delete/select on partition tables and ALTER TABLE. This test crashes repeatably shortly after takeoff with the following stack trace:

#3  0x00000000005a1510 in get_partition_id_key_nosub ()
#4  0x000000000071b66f in ha_partition::write_row ()
#5  0x0000000000716a41 in handler::ha_write_row ()
#6  0x00000000006bb330 in write_record ()
#7  0x00000000006ba5d6 in mysql_insert ()
#8  0x00000000006531a2 in mysql_execute_command ()
#9  0x0000000000657382 in mysql_parse ()
#10 0x000000000065054a in dispatch_command ()
#11 0x00000000006501bf in do_command ()
#12 0x000000000064e9ec in handle_one_connection ()
#13 0x00000033c04061b5 in start_thread () from /lib64/libpthread.so.0
#14 0x00000033bf8cd39d in clone () from /lib64/libc.so.6

More information will follow shortly.

How to repeat:
In the systems test directory:

Step 1. Change all mentions of innodb and myisam to Falcon.
Step 2. ./run_systest --scenario=iuds3_xddl.tst
[17 Jan 2008 11:45] Philip Stoev
Setting to verified since a test case is available. Can you please triage that bug and set it back to "need feedback" if a simpler test case is required?
[11 Feb 2008 16:25] Philip Stoev
Test case for bug 33691

Attachment: bug33691.test (application/octet-stream, text), 969 bytes.

[11 Feb 2008 16:55] Philip Stoev
I have uploaded a simpler straightforward test case which results in the same stack trace -- it appears that ALTER TABLE + INSERT + TRIGGER is what is needed to crash. Falcon is not required -- myisam table crashes too.

However, the latest mysql-6.0 does not crash.
[5 Mar 2008 13:25] Mattias Jonsson
I have not succeeded in verifying the problem in the mysql-5.1-engines or mysql-6.0-engines trees with the bug33691.test case. I will try the main trees since the latest bugfixes in partitioning is not there...
[5 Mar 2008 14:16] Mattias Jonsson
Philip, I have tested with both mysql-5.1 and mysql-6.0 main trees without hitting the bug, do you have any other test, or is it OK to close this bug?
[5 Mar 2008 14:49] Philip Stoev
It appears that the only tree this bug is reproducible on is mysql-6.0-falcon-team. The build team said that 6.0.5 will be built based on mysql-6.0, therefore the next release will be safe with respect to this bug. Thank you.