Bug #32966 main.status fails
Submitted: 4 Dec 2007 15:35 Modified: 22 May 2008 12:11
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Kristofer Pettersson CPU Architecture:Any
Triage: D3 (Medium)

[4 Dec 2007 15:35] Alexander Nozdrin
Description:
main.status                    [ fail ]

--- C:/cygwin/home/pushbuild/pb1/pb/mysql-5.1-runtime/583/mysql-5.1.23-rc-pb583/mysql-test/r/status.result	2007-11-30 15:00:35.000000000 +0300
+++ C:\cygwin\home\pushbuild\pb1\pb\mysql-5.1-runtime\583\mysql-5.1.23-rc-pb583\mysql-test\r\status.reject	2007-11-30 16:05:06.859375000 +0300
@@ -18,7 +18,7 @@
 unlock tables;
 show status like 'Table_locks_waited';
 Variable_name	Value
-Table_locks_waited	1
+Table_locks_waited	2
 drop table t1;
 select 1;
 1

mysqltest: Result content mismatch

Stopping All Servers
Restoring snapshot of databases
Resuming Tests

How to repeat:
https://intranet.mysql.com/secure/pushbuild/xref.pl?testname=main.status
[4 Dec 2007 15:49] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/39223

ChangeSet@1.2677, 2007-12-04 18:52:43+03:00, anozdrin@station. +1 -0
  Bug#32966 main.status fails.
  Disable failing test case.
[4 Dec 2007 15:51] Alexander Nozdrin
The test case disabled in 5.1-runtime.
[6 Dec 2007 9:59] Bugs System
Pushed into 5.1.23-rc
[6 Dec 2007 10:01] Bugs System
Pushed into 6.0.5-alpha
[6 Dec 2007 11:10] Sveta Smirnova
Set to verified as bug is repeatable in pushbuild.
[13 May 2008 14:10] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/46655

ChangeSet@1.2629, 2008-05-13 16:10:08+02:00, thek@adventure.(none) +3 -0
  Bug#32966 main.status fails
  
  FLUSH STATUS doesn't clear the values of the global status variables.
  The test case is reduced to testing session local Com-variables until
  FLUSH GLOBAL STATUS is implemented.
[14 May 2008 9:04] Kristofer Pettersson
Clarification: I can't reproduce the Table_locks_waited problem, but while enabling the test I discovered another issue which were corrected in the above patch.
[14 May 2008 9:18] Mattias Jonsson
Kristofer and I is not able to reproduce the original bug and after Kristofers change, we enable the test again. (if it still is a random error, we have to investigate further). OK to push.
[14 May 2008 12:46] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/46689

ChangeSet@1.2638, 2008-05-14 15:45:42+03:00, gkodinov@magare.gmz +1 -0
  Bug #32966: status still fails : disabling
[14 May 2008 13:21] Kristofer Pettersson
main.status                    [ fail ]

--- /data0/pushbuild/pb1-4/pb/mysql-5.1-bugteam/63/mysql-5.1.25-rc-pb63/mysql-test/r/status.result	2008-05-14 14:30:41.000000000 +0300
+++ /data0/pushbuild/pb1-4/pb/mysql-5.1-bugteam/63/mysql-5.1.25-rc-pb63/mysql-test/r/status.reject	2008-05-14 15:02:13.000000000 +0300
@@ -168,7 +168,6 @@
 Com_alter_function	0
 Com_create_function	0
 Com_drop_function	0
-Com_show_function_code	0
 Com_show_function_status	0
 create function f1 (x INTEGER) returns integer
 begin
@@ -182,5 +181,4 @@
 Com_alter_function	0
 Com_create_function	1
 Com_drop_function	1
-Com_show_function_code	0
 Com_show_function_status	0
[14 May 2008 15:20] Bugs System
Pushed into 5.1.25-rc
[20 May 2008 13:37] Kristofer Pettersson
PATCH pending via bzr:

=== modified file 'mysql-test/r/status.result'
--- mysql-test/r/status.result	2008-05-13 14:10:08 +0000
+++ mysql-test/r/status.result	2008-05-20 09:20:10 +0000
@@ -163,13 +163,11 @@
 rnd_diff	tmp_table_diff
 20	8
 flush status;
-show status like 'Com%function%';
+show global status like 'Com%function';
 Variable_name	Value
 Com_alter_function	0
 Com_create_function	0
 Com_drop_function	0
-Com_show_function_code	0
-Com_show_function_status	0
 create function f1 (x INTEGER) returns integer
 begin
 declare ret integer;
@@ -177,10 +175,8 @@
 return ret;
 end //
 drop function f1;
-show status like 'Com%function%';
+show global status like 'Com%function';
 Variable_name	Value
 Com_alter_function	0
 Com_create_function	1
 Com_drop_function	1
-Com_show_function_code	0
-Com_show_function_status	0

=== modified file 'mysql-test/t/disabled.def'
--- mysql-test/t/disabled.def	2008-05-15 09:50:04 +0000
+++ mysql-test/t/disabled.def	2008-05-20 09:20:10 +0000
@@ -13,7 +13,6 @@
 ps_ddl               : Bug#12093 2007-12-14 pending WL#4165 / WL#4166
 csv_alter_table      : Bug#33696 2008-01-21 pcrews no .result file - bug allows NULL columns in CSV tables
 user_limits     : Bug#23921 random failure of user_limits.test
-status               : Bug#32966 main.status fails
 thread_cache_size_func : Bug#36733 main.thread_cache_size_func fails randomly
 binlog_cache_size_basic_32            : Bug #36522: Some tests of system variables have diffs on 64bit platorms
 bulk_insert_buffer_size_basic_32      : Bug #36522: Some tests of system variables have diffs on 64bit platorms

=== modified file 'mysql-test/t/status.test'
--- mysql-test/t/status.test	2008-05-13 14:10:08 +0000
+++ mysql-test/t/status.test	2008-05-20 09:20:10 +0000
@@ -246,7 +246,7 @@
 # Bug#30252 Com_create_function is not incremented.
 #
 flush status;
-show status like 'Com%function%';
+show global status like 'Com%function';
 
 DELIMITER //;
 create function f1 (x INTEGER) returns integer
@@ -258,7 +258,7 @@
 DELIMITER ;//
 
 drop function f1;
-show status like 'Com%function%';
 
+show global status like 'Com%function';
 
 # End of 5.1 tests
[22 May 2008 9:50] Bugs System
Pushed into 6.0.6-alpha
[22 May 2008 12:11] Paul Dubois
Test case change. No changelog entry needed.
[28 Jul 2008 16:49] Bugs System
Pushed into 5.1.27  (revid:joerg@mysql.com-20080626161101-h5hsaluwtf05xdr2) (version source revid:joerg@mysql.com-20080626161101-h5hsaluwtf05xdr2) (pib:3)
[15 Aug 2008 13:56] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/51737

2583 Evgeny Potemkin	2008-08-15
      Bug#37908: Skipped access right check caused server crash.
      
      The check_table_access function initializes per-table grant info and performs
      access rights check. It wasn't called for SHOW STATUS statement thus left
      grants info uninitialized. In some cases this led to server crash. In other
      cases it allowed a user to check for presence/absence of arbitrary values in
      any tables.
      
      Now the check_table_access function is called when the SHOW STATUS statement
      uses any table except information.STATUS.