Bug #32882 Print to PDF and Export as Single Page PDF Relations for EER Diagram
Submitted: 30 Nov 2007 21:43 Modified: 28 Mar 2008 17:22
Reporter: Hunter Jensen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.10 SE Beta OS:Microsoft Windows (XP SP2)
Assigned to: CPU Architecture:Any
Tags: export, pdf
Triage: D2 (Serious)

[30 Nov 2007 21:43] Hunter Jensen
Description:
File->Print to PDF or Export as single page PDF. If the EER Diagram has 1:m non-identifying relations (this doesn't happen with identifying relationships), then they are displayed improperly in the PDF file. See attached file.

How to repeat:
Create new EER diagram with two tables. Add a 1:m non-identifying relationship between the two tables. Click File->Print to PDF.
[2 Dec 2007 12:26] Sveta Smirnova
Thank you for the report.

Verified as described.

Bug #32887 was marked as duplicate of this one.
[19 Mar 2008 19:09] Johannes Taxacher
this is fixed now (tested with SVN Rev 2809)
[28 Mar 2008 17:22] MC Brown
A note has been added to the 5.0.16rc changelog: 

A 1:m relation in a diagram would fail to be generated properly when exported as a PDF.