Bug #32768 Autoplace objects in new diagram bug
Submitted: 27 Nov 2007 13:40 Modified: 8 Dec 2007 21:43
Reporter: Pasha Seliverstov Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.10 se OS:Microsoft Windows (XP SP2)
Assigned to: CPU Architecture:Any
Tags: diagram

[27 Nov 2007 13:40] Pasha Seliverstov
Description:
At the last step of reverse engineering process, I check Autoplace objects in new diagram checkbox and it come up with exception "Unknown Exception Caught in c:\document and settings\mysqldev\my documents\visual studio 2005\projects\mysql-workbench-pro\backend\windows\wb.wr\src\Canvas.h at line 142"

How to repeat:
reverse engineering -> check Autoplace objects in new diagram checkbox
[27 Nov 2007 14:01] Sergei Tkachenko
Thanks for report.
Is this crash repeatable with the same data? If so, it would be helpful if you could provide us saved document (.wbm), gotten after reverse-engineering procedure but without auto-placing objects on diagram.
[27 Nov 2007 22:29] Pasha Seliverstov
screenshot

Attachment: WorkbenchMySql.jpg (image/jpeg, text), 125.30 KiB.

[27 Nov 2007 22:34] Pasha Seliverstov
The problem come up when I click "add diagram" icon right after the program shown up. I assume it is related to repaint diagram routine.
[1 Dec 2007 7:38] Valeriy Kravchuk
Thank you for a problem report. Please, try to repeat with a newer version, 5.0.10, and inform about the results.
[2 Dec 2007 7:00] Pasha Seliverstov
The same problem with version 5.10. It shows exactly the same error. The problem might come up because some libraries for drawing are not installed on my computer.
[2 Dec 2007 12:00] Sveta Smirnova
Thank you for the feedback.

I can not repeat described behaviour with my own environment. Please provide your schema (output of mysqldump --no-data)
[2 Dec 2007 18:28] Pasha Seliverstov
ok. Step by step:
1 Execute MySQLWorkbench.exe
2 There is a default schema mydb
3 click add Diagram icon
4 get error

So the schema is default "mydb" schema without tables or anything added.

P.S. Where is your development team located? Just curious. It seems like somewhere in Russia or Ukraine. :)
[2 Dec 2007 19:10] Pasha Seliverstov
The case is similar to Bug #32591, Bug #32622
[8 Dec 2007 21:43] Sveta Smirnova
Thank you for the feedback.

Marked as duplicate of bug #32591
[28 Feb 2008 12:35] Lies Depuydt
In MySQL Workbench 5.0 OSS (Software Rendering) 
no problem anymore after download version 5.0.14a 

(I'm using Windows Vista Business)