Bug #32046 slave fails with 'Relay log read failure: Could not parse relay log event entry'
Submitted: 2 Nov 2007 6:11 Modified: 28 Jan 2008 13:54
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.1.23 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Triage: D2 (Serious)

[2 Nov 2007 6:11] Shane Bester
Description:
when running the following statements in multiple threads against the master, i encountered some slave failures.

1x   drop temporary table if exists t1
1x   create temporary table t1(id int,data varchar(255),key(id))engine=heap
100x insert ignore into t1 values (?,'?')
100x update t1 set data='?' where id=?
1x   flush logs

1) crash
2) 'Relay log read failure: Could not parse relay log event entry' errors

Trying to keep bug report tidy, so please see attached file(s) for the full errors and show slave status.

How to repeat:
setup basic replication scenario.

compile the attached c testcase and point it to the master.
wait for 10 - 60 minutes for the slave to put errors in it's error log (or crash!)
[2 Nov 2007 7:50] Shane Bester
see header for compilation instructions. point to master and run.

Attachment: bug32046.c (text/plain), 6.40 KiB.

[2 Nov 2007 7:51] Shane Bester
sample show slave status and error log after 10 minutes of running testcase...

Attachment: show_slave_status.txt (text/plain), 4.98 KiB.

[2 Nov 2007 7:55] Shane Bester
after repeating the slave errors on a clean setup 4 times with the supplied testcase, I am setting this to verified.
[2 Nov 2007 9:55] Shane Bester
I haven't been able to repeat this on 5.0 yet.  Will try more.
[28 Jan 2008 13:54] Mats Kindahl
Duplicate of BUG#32046
[28 Jan 2008 13:54] Lars Thalmann
Duplicate of BUG#26489