Bug #32019 Server does not start after Leopard install
Submitted: 1 Nov 2007 7:28 Modified: 13 Nov 2007 9:06
Reporter: Michael Grom Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:5.0 OS:Mac OS X (Leopard)
Assigned to: CPU Architecture:Any
Tags: client, command line, leopard, preference pane, Server start

[1 Nov 2007 7:28] Michael Grom
Description:
The server does not start after install of MacOS X Leopard Client (upgrade from an existing Tiger system). Neither via Preference Pane nor from the command line. Hint: no mysql user exists (but _mysql !) and the user management might have changed significantly (no netinfo) between Tiger and Leopard.

Re-install of 5.0 (MacOS X package format) did not fix the problem.

How to repeat:
Install Community server 5.0 on MacOS X Leopard (client) and try to start the server
[4 Nov 2007 4:21] Ljuba Miljkovic
There is a work around until this bug is fixed:

http://angry-fly.com/index.cfm/2007/10/26/Fix-for-MySQL-on-Leopard
[11 Nov 2007 17:20] Joannou Ng
Instead of manually starting MySQL between reboots, use launchd, as outlined here:
http://blog.tomatocheese.com/archives/2007/11/1/migrating_mysql_to_mac_os_x_leopard/
[13 Nov 2007 9:06] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #28854
[7 Mar 2008 7:55] Mattias Jonsson
Just for reference, Bug#28854 is the MySQL.prefPane not working in Mac OS X 10.5 and bug#25008 is the non working StartupItem.pkg.