Bug #30140 log_error in my.cnf shows different behaviour than log-error
Submitted: 31 Jul 2007 10:03 Modified: 8 May 2009 9:12
Reporter: Oli Sennhauser Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Logging Severity:S3 (Non-critical)
Version:5.0.45, 5.1 OS:Any
Assigned to: CPU Architecture:Any
Triage: Triaged: D3 (Medium)

[31 Jul 2007 10:03] Oli Sennhauser
Description:
The usage of the my.cnf variables log_error and log-error shows a different behavior. Which is strange and ugly.

How to repeat:
# cat my.cnf
[client]
port          = 3316
socket        = /home/mysql/tmp/mysql-3316.sock
[mysqld]
port          = 3316
socket        = /home/mysql/tmp/mysql-3316.sock
log_error     = error.log

# start

# ls *err*
error.log  master.err

# cat my.cnf
[client]
port          = 3316
socket        = /home/mysql/tmp/mysql-3316.sock
[mysqld]
port          = 3316
socket        = /home/mysql/tmp/mysql-3316.sock
log-error     = error.log

# start

# ls *err*
error.log

Suggested fix:
make them both behave equal to log-error
[31 Jul 2007 12:10] Hartmut Holzgraefe
probably a duplicate of bug #30139
[31 Jul 2007 12:37] Sveta Smirnova
Thank you for the report.

Verified as described.
[8 May 2009 1:16] Jim Winstead
This sounds like a duplicate of Bug #40368. Can you try the patch for that bug to see if it fixes your problem?
[8 May 2009 9:12] Sveta Smirnova
Confirmed this is duplicate of Bug #40368.