Bug #29149 Test "kill" fails on Windows
Submitted: 15 Jun 2007 21:07 Modified: 7 Apr 2010 11:42
Reporter: Joerg Bruehe Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:4.1.21 and up OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: pbfail
Triage: Triaged: D3 (Medium)

[15 Jun 2007 21:07] Joerg Bruehe
Description:
The effect is well-known since (at least) 4.1.21, but I didn't find a report about it:

kill                           [ fail ]

Errors are (from /PATH/mysqltest-time) :
mysqltest: At line 32: query 'select 1' succeeded - should have failed with errno 2006...
(the last lines may be the most important ones)
Result from queries before failure can be found in r/kill.log

How to repeat:
Run the test suite on a Windows build.
[26 Nov 2007 14:35] Ingo Strüwing
The test fails differently now.

main.kill                      [ fail ]

mysqltest: At line 243: query 'reap' succeeded - should have failed with errno 1317...

The result from queries just before the failure was:
< snip >
declare continue handler for sqlexception set @a:= 'exception';
select get_lock("lock27563",10);
select "shouldn't be selected";
end|
call proc27563();
get_lock("lock27563",10)
NULL
ERROR 70100: Query execution was interrupted
select @a;
@a
NULL
create table t2 (f2 int);
create trigger trg27563 before insert on t1 for each row 
begin 
declare continue handler for sqlstate '70100' set @a:= 'killed';
declare continue handler for sqlexception set @a:= 'exception';
set @a:= get_lock("lock27563",10);
insert into t2 values(1);
end|
insert into t1 values(2),(3);

More results from queries before failure can be found in e:\var-n_mix-100\log\kill.log

See pushbuild https://intranet.mysql.com/secure/pushbuild/showdir.pl?dir=mysql-5.1-engines
log https://intranet.mysql.com/secure/pushbuild/getlog.pl?dir=mysql-5.1-engines&entry=istruewi...
See also https://intranet.mysql.com/secure/pushbuild/xref.pl?startdate=&enddate=&dir=&plat=&testtyp...

Disabling the test case. Please re-enable after fix.
[28 Nov 2007 10:24] Bugs System
Pushed into 6.0.4-alpha
[28 Nov 2007 10:26] Bugs System
Pushed into 5.1.23-rc
[28 Nov 2007 10:27] Bugs System
Pushed into 5.0.54
[12 May 2009 21:11] Jim Winstead
Bug is not fixed, test is just disabled.
[2 Jul 2009 8:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/77737

2790 Sergey Glukhov	2009-07-02
      Bug#29149 Test "kill" fails on Windows
      enabled test
     @ mysql-test/t/disabled.def
        enabled test
[7 Apr 2010 11:42] Georgi Kodinov
Closing as duplicate of bug #37780