Bug #28680 Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
Submitted: 25 May 2007 14:22 Modified: 8 May 2008 8:28
Reporter: Anthony Willard (Basic Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:6.0.0-alpha-community-nt-debug OS:Microsoft Windows (XP SP2)
Assigned to: Iggy Galarza CPU Architecture:Any
Tags: qc
Triage: D3 (Medium)

[25 May 2007 14:22] Anthony Willard
Description:
[ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist in {server}.err log file.

full file:
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
070525  9:17:42  InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
070525  9:17:43  InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 10 MB
InnoDB: Database physically writes the file full: wait...
070525  9:17:43  InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
070525  9:17:44  InnoDB: Started; log sequence number 0 0
070525  9:17:44 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
070525  9:17:44 [Note] C:\Program Files\MySQL\MySQL Server 6.0\bin\mysqld-nt: ready for connections.
Version: '6.0.0-alpha-community-nt-debug'  socket: ''  port: 3306  MySQL Community Server (GPL)
070525  9:17:44 [Note] Event Scheduler: Loaded 0 events

How to repeat:
Fresh install of the 6.0 Alpha software.

Selected Typical installation, default configuration of the server.

This was done to a machine where v6 was installed and removed, then the entire folders removed, so there was nothing remaining from a former installation.

Suggested fix:
Include the definition and default data for the mysql.servers table in the install.
[25 May 2007 16:54] Hakan Küçükyılmaz
Anthony,

did you try to run the mysql_fix_privilege_tables script? It should fix the privileges tables.

Best regards,

Hakan
[25 May 2007 17:42] Anthony Willard
Yes, I found the script and ran it.  It created the tables and a restart did not produce any errors in the log.

Why was it not part of the install process?  There was no message stating it should be run.
[25 May 2007 18:04] Trudy Pelzer
Changing bug type to "installing"; this is not specifically
a Falcon bug.
[6 Jun 2007 12:17] Andrey Hristov
Probably missing from the config file for the MSI packager.
[8 Jul 2007 16:04] Louis Breda van
Hello,

Exactly the same problem when installing 5120 64 bit on vista64. 

The work arround is to run the script. So from that point of view this bug is not critical. However, IMHO it is very SERIEUS that packages are not checked against a "good" basic testset, before they are released!

Sincerely,

Louis
[13 Dec 2007 15:54] Daniel Fischer
Needs to be re-verified, likely fixed by other changes.
[15 Feb 2008 8:52] Philip Stoev
This problem still exists in a sense that once you have installed 6.0.2 on Windows and got that error, upgrading to 6.0.4 will fail. I assume that the 6.0.4 mysql_upgrade.exe is not prepared to handle this situation.

Steps to reproduce:

1. Install 6.0.2

2. Install 6.0.4 in same directory. 6.0.2 service will be stopped and 6.0.2 will be uninstalled.

3. The 6.0.4 configuration wizard will start the service, however will then report that it can not "Apply security settings" due to "access denied"
[15 Feb 2008 9:10] Philip Stoev
Actually please disregard my previous comment -- it must be due to some other issue. A vanilla 6.0.4 installation in a clean directory also prints this error message in the Application Event Log.

Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
[5 Mar 2008 21:12] Louis Breda van
Hello,

I wonder when this serieus bug, which is already there for at least a year, will (at the end) be fixed.

Can't be too hard IMHO.

Note that I see it also on a fresh 5.1.23 install on both vista64 as well as xp32. Please fix it also iun 5.x !!!!!

Sincerely,

Louis
[23 Mar 2008 20:10] Amit Joshi
Same error occurred on my win xp 64  machine as well. Any solution?
[8 Apr 2008 20:40] Sveta Smirnova
There is same report for 5.1: bug #32797
[22 Apr 2008 19:06] Iggy Galarza
Add missing default database files to installer packages.

Attachment: Bug28680.patch (text/x-patch), 1.95 KiB.

[23 Apr 2008 21:04] Patrick Crews
Ok to push.
[29 Apr 2008 16:08] Iggy Galarza
Pushed changes for 6.0 to the mysql-server-setup repository today.  The next time the 6.0 installers are built all the default system tables will be included in the package.
[30 Apr 2008 2:54] Paul Dubois
Noted in 6.0.6 changelog.

The mysql.servers table was not created during installation on
Windows.
[8 May 2008 8:24] Sveta Smirnova
Has it fixed in version 5.1?
[8 May 2008 8:28] Sveta Smirnova
Please ignore previous comment: fix for 5.1.25 is reflected in bug #32797
[10 Jun 2008 0:25] Jared S
Bug appears NOT to be fixed in 5.1.25!

Trying to start the server ...
Server was started.
Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist

Event Scheduler: Loaded 0 events

C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.25-rc-community-log'  socket: ''  port: 3306  MySQL Community Server (GPL)

---

080610 10:21:04  InnoDB: Started; log sequence number 0 344477913
080610 10:21:04 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
080610 10:21:04 [Note] Event Scheduler: Loaded 0 events
080610 10:21:04 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
[13 Jul 2008 23:32] Jared S
Fixed in 5.1.26 >> http://bugs.mysql.com/bug.php?id=36434

c:\Program Files\MySQL\MySQL Server 5.1 
c:\Program Data\MySQL\

Need to be cleared on upgrade sometimes.