Bug #32797 mysql.server table doesn't exist on windows and gives error in event viewer
Submitted: 27 Nov 2007 23:04 Modified: 30 Apr 2008 2:57
Reporter: Tobias Asplund Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:5.1.22 OS:Microsoft Windows
Assigned to: Iggy Galarza CPU Architecture:Any
Triage: D2 (Serious)

[27 Nov 2007 23:04] Tobias Asplund
Description:
After installing MySQL 5.1.22 on a Windows system, start it up normally and then check the event viewer.
There's an error there that we can't lock the mysql.server table.
This table should probably be in the default Windows installation.

How to repeat:
1. Install MySQL for Windows (I used the graphic installer and the "Essentials" package, but it probably exists in all packages).
2. Install and start the server.
3. Check the Event viewer under "Control Panel=>Administrative Tools=>Event Viewer=>Application log=> voila :)
[28 Nov 2007 4:35] Valeriy Kravchuk
Thank you for a bug report. Verified just as described. The exact mesage is:

"Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist"
[29 Feb 2008 16:17] Trudy Pelzer
Workaround for this:
Run the mysql_fix_privilege_tables.sql with the 
--force flag against the mysql database seems to 
fix it.
[8 Apr 2008 20:39] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=35911 has been marked as duplicate
of this bug.
[23 Apr 2008 21:03] Patrick Crews
Ok to push.
[30 Apr 2008 2:57] Paul Dubois
Noted in 5.1.25 changelog.

The mysql.servers table was not created during installation on
Windows.
[9 Jun 2008 15:13] Iggy Galarza
Marked 34487 as a duplicate of this bug.