Bug #28471 System Tray Monitor unable to start/stop MySQL service on Vista
Submitted: 16 May 2007 15:18 Modified: 16 May 2007 22:09
Reporter: Ben Eng Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL GUI Common Severity:S3 (Non-critical)
Version:5.0-r12 OS:Microsoft Windows (Vista)
Assigned to: CPU Architecture:Any
Tags: monitor, service, tray, vista

[16 May 2007 15:18] Ben Eng
Description:
Starting and stopping an instance of a MySQL service fails on Microsoft Windows Vista.

Workaround: the user can continue to start and stop the MySQL service through the Windows Control Panel applet for Services.

This failure impacts the convenience of performing this function.

This probably has something to do with Vista's changes to securing functions that require Administrator permissions, even when logged in as a user who has Administrator privileges. Normally, Windows pops up a dialog to confirm the elevation of privileges, when a program (e.g., an installer) needs them. However, this dialog is not appearing when starting or stopping a MySQL instance from the MySQL System Tray Monitor. This is probably an indication that Administrator privileges are not being requested and granted.

How to repeat:
Install MySQL on Vista. Install the GUI tools.

Start and stop the MySQL instance from the MySQL System Tray Monitor.
[16 May 2007 22:09] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of the bug #23746