Bug #23746 MySQL System Tray Monitor can not start/stop mysql service in Vista OS
Submitted: 28 Oct 2006 17:11 Modified: 6 Feb 2009 9:57
Reporter: Weipeng Zhao Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.11 OS:Microsoft Windows (Windows Vista, XP SP2)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: service, vista

[28 Oct 2006 17:11] Weipeng Zhao
Description:
Hello,
My OS is Windows Vista 5744, MySQL's version is 5.0.24, mysql gui tools's version is 5.0-r4.
I can not start/shutdown instance by "MySQL System Tray Monitor" in Vista, and it pop-up a alert windows with message "Could not start service".
But MySQL Service can be start/stop in Vista Service Manager.
MySQL DB works very well in Vista.

Thank you

How to repeat:
use vista
[30 Oct 2006 11:05] Sveta Smirnova
Thank you for the report.

Verified on Windows XP SP2 as described.
[1 Nov 2006 10:03] Mike Lischke
I cannot reproduce this problem. I have an installation with 4 servers and I could start and stop each one to my hearts liking, except for one case where I had no port setting in my.ini and two servers tried to use the same TCP/IP port.

I actually tried on an XP SP2 machine, so it might still be a bit different on others. Do you both have admin rights when you try to start the services? Can you manipulate them with MA instead only the tray monitor?
[1 Nov 2006 19:45] Sveta Smirnova
Weipeng,

how much MySQL servers have you running on the same machine? Please could you provide configuration file for server you can't restart?
[2 Dec 2006 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[15 Mar 2007 20:51] Kevin Claver
This is an issue with Vista and remains on the latest version.  The System Tray Monitor requires admin privileges and Vista will not allow the Tray Monitor to be started via the Startup menu as a result.
[12 Apr 2007 9:13] Sveta Smirnova
Thank you for the feedback.

To repeat it on Vista UAC should be turned on.

Workaround: turn off UAC.
[15 May 2007 22:49] Alejandro CastaƱaza
I'm running Windows Vista and the tray monitor does not start/stop mysql service as described above.
My solution is to start MySql Administrator with elevated privileges (changed the shortcut to Run as Administrator), so I can start or stop the service using the Administrator.
The only problem is that every time I run mysql administrator, windows asks for permission (uac).
[16 May 2007 22:10] Sveta Smirnova
Bug #28471 was marked as duplicate of this one.
[17 Jul 2007 16:46] MySQL Verification Team
Bug: http://bugs.mysql.com/bug.php?id=28324 was marked as duplicate of
this one.
[10 Sep 2008 3:16] Antonio Balleras
Hi,

I tried setting the system tray application to run as an administrator. Its located on the property settings of the icon system tray, it solve the problem of not being able to start and stop mysql server.

this does not need you to turn off the UAC

i hope this helps.
[6 Feb 2009 9:57] Mike Lischke
Thank you for your bug report. This issue has already been fixed in the latest released version of that product, which you can download at

  http://www.mysql.com/downloads/