Bug #28324 not able to start mysql server service on windows vista
Submitted: 9 May 2007 3:46 Modified: 17 Jul 2007 17:15
Reporter: Biju Singh Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.0 OS:Microsoft Windows (Windows Vista Home Premium)
Assigned to:
Tags: not able to start mysql server service on windows vista

[9 May 2007 3:46] Biju Singh
Description:
Hi all, 

I am using Windows Vista and recently installed MySql Ver 5.0.37, for Win32. Now when I try to configure the MySql server instance by launching INSTANCE CONFIG WIZARD and at the end when I click on EXECUTE button I am seeing that the MySql Service is not started. 

Could anyone please let me know how to start service of MySql database on Windows Vista?? 

Is is security problem with Vista? 

Thanks in adv 

Biju

How to repeat:
Just install fresh and try to use "MySql Server Instance Configuration".

Suggested fix:
Should be able to start the Server service
[11 May 2007 13:30] Miguel Solorzano
Thank you for the bug report. I was unable to repeat this issue on Windows
Vista Ultimate:

Microsoft Windows [versão 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. Todos os direitos reservados.

C:\Windows\system32>sc query MySQL

NOME_DO_SERVIÇO: MySQL
    TIPO                       : 10  WIN32_OWN_PROCESS
    ESTADO                     : 4  RUNNING
                                (STOPPABLE, PAUSABLE, ACCEPTS_SHUTDOWN)
    CÓDIGO_DE_SAÍDA_DO_WIN32   : 0  (0x0)
    CÓDIGO_DE_SAÍDA_DO_SERVIÇO : 0  (0x0)
    PONTO_DE_VERIFICAÇÃO       : 0x0
    AGUARDAR_DICA              : 0x0

C:\Windows\system32>

If you still has this problem, please open a DOS prompt with Administrator
privileges and go to MySQL \bin install directory and issue:

mysqld-nt --defaults-file="path_for_the_my.ini" --standalone --console

and print here eventual error messages printed. Thanks in advance.
[12 May 2007 11:19] Biju Singh
Hi,
Here is the result of the command:

C:\Program Files\MySQL\MySQL Server 5.0\bin>mysqld-nt --defaults-file="C:\Progra
m Files\MySQL\MySQL Server 5.0\my.ini" --standalone --console
InnoDB: No valid checkpoint found.
InnoDB: If this error appears when you are creating an InnoDB database,
InnoDB: the problem may be that during an earlier attempt you managed
InnoDB: to create the InnoDB data files, but log file creation failed.
InnoDB: If that is the case, please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/error-creating-innodb.html
070512  7:27:33 [ERROR] Default storage engine (InnoDB) is not available
070512  7:27:33 [ERROR] Aborting

070512  7:27:33 [Note] mysqld-nt: Shutdown complete

C:\Program Files\MySQL\MySQL Server 5.0\bin>

Thanks,
Biju
[12 May 2007 11:20] Biju Singh
screen shot of the error while configuring the service

Attachment: mysqlstarterr.jpg (image/pjpeg, text), 28.64 KiB.

[12 May 2007 11:21] Biju Singh
my windows details

Attachment: windowsdetails.jpeg (image/pjpeg, text), 47.21 KiB.

[12 May 2007 11:21] Biju Singh
my windows details

Attachment: windowsdetails.jpeg (image/pjpeg, text), 47.21 KiB.

[12 May 2007 11:21] Biju Singh
Please see the attached screen shots..
Biju
[12 May 2007 19:37] Miguel Solorzano
Thank you for the feedback. So something wrong happened when creating
the InnoDB files, IF YOU DON'T HAVE ANY DATA (it is a fresh install) so
you can delete all these InnoDB files and to create them again with a
new start. So how I asked you before go to install directory and delete
the below files:

c:\Arquivos de programas\mysql\MySQL Server 5.0\data>dir ib*
 O volume na unidade C não tem nome.
 O Número de Série do Volume é DCC1-39C2

 Pasta de c:\Arquivos de programas\mysql\MySQL Server 5.0\data

12/05/2007  01:34        60.817.408 ibdata1
12/05/2007  14:13        10.485.760 ib_logfile0
12/05/2007  14:13        10.485.760 ib_logfile1
               3 arquivo(s)     81.788.928 bytes
               0 pasta(s)   45.475.278.848 bytes disponíveis

c:\Arquivos de programas\mysql\MySQL Server 5.0\data>

and try to start the server how I asked you before.

If the server starts as standalone without any problems, then
do the shutdown:

mysqladmin -uroot shutdown

and try to start the service.
[14 May 2007 1:33] Biju Singh
Hi I searched those files in my laptop. They are not present in my pc. I have used this DB before also and never found any problem. It seems, there is some problem with Windows Vista. Could you please check if it is able to open the port 3306 on the localhost without changing any settings on Windows Vista? 

The server is not running in my pc so there doesnt arise any question of shutting down.

Thanks,
Biju
[15 May 2007 14:26] Miguel Solorzano
Thank you for the feedback. How I said you I had not problems to setup
MySQL on my Windows Vista, however notice that I installed with Administrator
privileges otherwise you will have problems like that.
[16 May 2007 2:35] Biju Singh
Hi,
I have admin privileges with my account, thats why I am able to install all the softwares. But not able to start the MySql service.

Thanks,
Biju
[16 May 2007 9:24] Michael Emmerson
This isn't a bug, I got the same error. It's a common problem in vista but also the easiest to fix.

Simply right-click the setup file (instant config one) then select 'run as administrator' as i'm sure the previus guy meant..

This worked on my Vista Ultimate,
Hope it helps...

MRE64
[17 May 2007 1:25] Biju Singh
Hi,
I tried even running it as Admin but it didn't work for me. Could you please try to dupe it on Windows Vista Home Premium? 

Thanks,
Biju
[22 May 2007 16:21] Don Ashley
I'm not even sure this is related to Vista Ultimate. I got the very same errors in XP Media, which is why I upgraded to Ultimate thinking MySql didn't play nice with the XP Media. I got the very same condition that is described here. I've tried reinstalling at least 4 times, checked issues regarding processes running that might conflict or those that weren't running on which MySql might depend. What I discovered might be an incorrect assumption, but apparently some of the SQL Server drivers or processes are related in some way to MySql. Therefore I uninstalled both Sql Server and MySql, reinstalled both--just seems to be the very same. I haven't seen MySql power yet! Please find this?
[12 Jun 2007 8:47] Marine Lachaud
Hi 
Is this bug related with the bug #23746 ?
It looks like.
[22 Jun 2007 19:27] Rahul V Shah
Hello Miguel Solorzano,
  Your patch worked well to start Mysql on Vista. Thanks a lot for your help.

Regards
Rahul
[22 Jun 2007 20:59] Biju Singh
Yes, it looks similar with  bug #23746. What is the Patch that Rahul is talking about. Is it a solution for my prob? Could you please forward it to me also to try it out? 

Thanks,
Biju
[23 Jun 2007 13:06] Rahul V Shah
Hi Biju,
  I was facing the same problem, I performed the suugested command C:\Program Files\MySQL\MySQL Server 5.0\bin>mysqld-nt --defaults-file="C:\Progra
m Files\MySQL\MySQL Server 5.0\my.ini" --standalone --console and then got the same error which you got. Then as per the suggestion I cleaned up the Innodb files and then things started working for me without any issue. My login has administrative access on my Vista OS.

Regards
Rahul
[7 Jul 2007 4:08] Biju Singh
Any update on this? Please let me know if you have any solution for this prob?

Thanks,
Biju
[17 Jul 2007 16:44] Miguel Solorzano
Duplicate of bug: http://bugs.mysql.com/bug.php?id=23746.
[17 Jul 2007 17:15] Biju Singh
Thats fine. Looks same issue. Any solution ??
Thanks,
Biju