Bug #28316 Fatal crash with Crystal Reports and SQL Server 5.0.40
Submitted: 9 May 2007 0:48 Modified: 16 Mar 2009 22:16
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.15 OS:Microsoft Windows (Vista, XP)
Assigned to: Georg Richter CPU Architecture:Any
Tags: cr, crash

[9 May 2007 0:48] Jared S
Description:
Hi, ODBC crashes Crystal Report 11 Release 2 on Vista RTM when accessing MySQL Server databse 5.0.40.  The basic task I am trying to accomplish is 'Database Expert' using current connection.

How to repeat:
1. Install MySQL 5.0.40 onto Vist\XP
2. Install Crystal Reports 11
3. Create new report
4. Try to configure ODBC

RESULT Crystal Reports comes down in flames
[10 May 2007 12:19] Tonci Grgin
Hi Jared. I am currently having problems with CR license so this will have to wait...
[11 May 2007 4:35] Jared S
http://www.download.com/Crystal-Reports/3000-10258_4-10395547.html

== OR ==

http://www.businessobjects.com/products/reporting/crystalreports/default.asp

Don't think not having 'Release 2' of CRXI is going to impact this bug.
[11 May 2007 8:00] Tonci Grgin
Doesn't work for me (anymore)...
[11 May 2007 8:22] Jared S
crw32           e5c-838	ENTER SQLProceduresW 
		HSTMT               7FD8E950
		WCHAR *             0x00000000 [      -3] <empty string>
		SWORD                       -3 
		WCHAR *             0x00000000 [      -3] <empty string>
		SWORD                       -3 
		WCHAR *             0x00000000 [      -3] <empty string>
		SWORD                       -3
[11 May 2007 8:23] Jared S
log for odbc 3.51.15 crash

Attachment: SQL.LOG (application/octet-stream, text), 18.60 KiB.

[11 May 2007 10:23] Tonci Grgin
No no no, troubles begun earlier, with malformed connection string... I don't think I'll be able to resolve this, taken in account the hidden remark especially, without CR... I can't think of an easy way for you to pass me the actual connect string CR uses.
[11 May 2007 10:55] Jared S
Have you considered installing VMWare or Virtual PC 2007 to allow for fresh CR demo?  HDD space allowing.
[11 May 2007 11:44] Jared S
Is a progression of one of following..

http://dev.mysql.com/doc/refman/5.0/en/myodbc-news-3-51-15.html

http://bugs.mysql.com/27589
http://bugs.mysql.com/24306
http://bugs.mysql.com/23033
http://bugs.mysql.com/4518
http://bugs.mysql.com/5853
http://bugs.mysql.com/21588
[5 Jun 2007 19:14] Ziyaad Sayed
Hi. The name is Ziyaad. I am having the same problem with Crystal Reports Developer R2 using MySQL 5 on win XP platform. 

The problem is with the mysql ODBC connector version 3.51 because when i tried another odbc connector from an independant software company crystal reports connects to the mySQL database. The only problem is that the cost of this odbc connector is charged based on the no of connections and this turns out to be expensive.

I have been checking this forum everyday to see if there is a solution and i am very concerned as this problem is outstanding for almost a month and counting and i cannot do any development. Please advise when a solution will be made available. Sorry for all the trouble!!! thnx
[5 Jun 2007 23:15] Jared S
Think outside of the box, downgrade your 3rd party components...
http://dev.mysql.com/get/Downloads/MyODBC3/mysql-connector-odbc-3.51.14-win32.msi/from/htt...

Notice the number (4) in the above web link.

Please state your versions so we can confirm your issue.
[6 Jun 2007 10:12] Ziyaad Sayed
Hi Jared.

It seems to be working version 3.51.14

Thnx alot. I have been looking for previous versions but could not find the link.

Are there any issues with 3.51.14

Keep well !!!

Ziyaad
[6 Jun 2007 23:00] Jared S
Well kinda, you only get one chance at editing System DSN for 3.51.14 and then you have to delete it using registry editor :)
[11 Jun 2007 9:13] Tonci Grgin
Hi Jared... Again, you are right, "in flames" seems to be the right expression. I'm setting this report to verified state as I've already wasted valuable time. This needs a lot more investigation so I'll continue working...

Environment:
 - MySQL server 5.0.44BK on WinXP Pro SP2 localhost
 - MyODBC 3.51.12
 - CR XI developer
 - Clean SystemDSN (Option=1)
[11 Jun 2007 9:18] Tonci Grgin
Crashes with my usual SystemDSN (auto reconnect, forward only cursor etc) too.
[11 Jun 2007 11:18] Georg Richter
Fix for SQLProcedures (checking NULL parameters)

Attachment: bug28316.patch (text/x-patch), 3.60 KiB.

[11 Jun 2007 16:17] Jim Winstead
Okay to push, with the following changes:

* Make sure there are two blank lines before the added test.
* Add header to the added test.
* Remove unused SQLRETURN rc from test.
* Don't add line before MYODBCDbgEnter

/**
 Bug #28316: Fatal crash with Crystal Reports and SQL Server 5.0.40
*/
[13 Jun 2007 13:44] Bogdan Degtyariov
Although my Crystal Reports does not crash in any case, the test case included in my_catalog crashes when the patch is not applied. I suppose the problem has been solved as it fixes the problem when calling SQLProcedures(NULL, SQL_NTS, NULL, SQL_NTS, NULL, SQL_NTS)
[16 Jun 2007 5:37] Georg Richter
Fix committed. Will appear in 3.51.17
[4 Jul 2007 0:23] Paul Dubois
Noted in 3.51.17 changelog.

Connector/ODBC crashed with Crystal Reports.
[15 Jan 2009 11:09] sheril sher
try this

http://vb.net-informations.com/crystal-report/vb.net_crystal_reports_tutorials.htm
[16 Mar 2009 22:16] Jared S
IRT? FYI article is outdated as well.