Bug #27769 MySQL should include debian packaing dir
Submitted: 11 Apr 2007 21:05 Modified: 4 Jan 2008 17:48
Reporter: Monty Taylor Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:5.0, 5.1 OS:Linux
Assigned to: Monty Taylor CPU Architecture:Any
Triage: D4 (Minor)

[11 Apr 2007 21:05] Monty Taylor
Description:
In order to build debian packages, a debian dir is needed. In order to manage this well for mysql versions, it should go in bk so that the version branching can be leveraged. 

How to repeat:
ls | grep debian

Suggested fix:
Add the debian dir to the bk sources and to the source dists.
[12 Apr 2007 23:36] Monty Taylor
Debian dir pushed to -maint tree of 5.0 and 5.1.
[13 Apr 2007 18:39] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24518

ChangeSet@1.2584, 2007-04-13 11:39:00-07:00, mtaylor@qualinost.(none) +2 -0
  Branching debian code for 5.1
  BUG#27769 - MySQL should include debian packaging dir
[13 Apr 2007 18:45] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24519

ChangeSet@1.2456, 2007-04-13 11:44:55-07:00, mtaylor@qualinost.(none) +1 -0
  BUG#27769 - MySQL should include debian packaging dir
  Replaced hardcoded sover reference with variable.
  Removed references to added manpages.
[13 Apr 2007 20:47] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24527

ChangeSet@1.2457, 2007-04-13 13:47:17-07:00, mtaylor@qualinost.(none) +3 -0
  BUG#27769 
  Cleaned up some things to make building the packages go a little smoother.
[17 Apr 2007 15:04] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24678

ChangeSet@1.2456, 2007-04-17 08:04:32-07:00, mtaylor@qualinost.(none) +3 -0
  BUG#27769 - MySQL should include debian packaging dir
  Replaced hardcoded sover reference with variable.
  Removed references to added manpages.
  ---
  BUG#27769 
  Cleaned up some things to make building the packages go a little smoother. 
  ---
  debian/rules really does need to be called from the source root.
  ---
  Fixed two problems with the build caused by adding debian to the source tree
  ---
  Left off the debian/ prefix to the Makefile filter.
[17 Apr 2007 19:35] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24705

ChangeSet@1.2457, 2007-04-17 12:34:55-07:00, mtaylor@qualinost.(none) +62 -0
  BUG#27769 - MySQL should include debian packaging dir
  Changed substitution variables to match already existing autoconf vars.
  Generate debian/control and debian/defs.mk from autoconf now, since we run that
  to make a source package.
[17 Apr 2007 20:14] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24709

ChangeSet@1.2456, 2007-04-17 13:14:29-07:00, mtaylor@qualinost.(none) +61 -0
  BUG#27769 - MySQL should include debian packaging dir
  Replaced hardcoded sover reference with variable.
  Removed references to added manpages.
  ---
  BUG#27769 
  Cleaned up some things to make building the packages go a little smoother. 
  ---
  debian/rules really does need to be called from the source root.
  ---
  Fixed two problems with the build caused by adding debian to the source tree
  ---
  Left off the debian/ prefix to the Makefile filter.
  ---
  BUG#27769 - MySQL should include debian packaging dir
  Changed substitution variables to match already existing autoconf vars.
  Generate debian/control and debian/defs.mk from autoconf now, since we run that
  to make a source package. 
  ---
  Corrected incorrect variable name
  ---
  Renamed template files to have shorter names.
[18 Apr 2007 1:13] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/24736

ChangeSet@1.2456, 2007-04-17 18:12:43-07:00, mtaylor@qualinost.(none) +62 -0
  BUG#27769 - MySQL should include debian packaging dir
  Replaced hardcoded sover reference with variable.
  Removed references to added manpages.
  ---
  BUG#27769 
  Cleaned up some things to make building the packages go a little smoother. 
  ---
  debian/rules really does need to be called from the source root.
  ---
  Fixed two problems with the build caused by adding debian to the source tree
  ---
  Left off the debian/ prefix to the Makefile filter.
  ---
  BUG#27769 - MySQL should include debian packaging dir
  Changed substitution variables to match already existing autoconf vars.
  Generate debian/control and debian/defs.mk from autoconf now, since we run that
  to make a source package. 
  ---
  Corrected incorrect variable name
  ---
  Renamed template files to have shorter names. 
  ---
  Moved generation of debian/control to dist-hook so make clean won't eat it.
  ---
  A few final changes to make debs build from a source tarball dist.
[26 Apr 2007 11:36] Bugs System
Pushed into 5.1.18-beta
[26 Apr 2007 11:37] Bugs System
Pushed into 5.0.42
[4 Jan 2008 17:48] Daniel Fischer
The debian/ directory was added, but later removed. This bug report is no longer relevant.