Bug #27315 Configure\Remove User\System DSN causes crash
Submitted: 21 Mar 2007 3:18 Modified: 20 Jul 2007 11:49
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.14 OS:Microsoft Windows (Windows Vista\XP SP2)
Assigned to: Jess Balint
Tags: configure, data sources, DSN, ODBC, system, user, vistaб йс

[21 Mar 2007 3:18] Jared S
Description:
It is not possible to alter properties of a Windows ODBC DSN ounce created.  MySQL ODBC will always throw an erro (on Vista at least)

How to repeat:
1. Install mysql-connector-odbc-3.51.14-win32 onto a Vista box
2. Set up new MySQL ODBC DSN
2. Try to configure\remove the new DSN buy hitting the 'Configure' button

Suggested fix:
Buy Windows Vista and perform basic test before you release.
[21 Mar 2007 3:19] Jared S
first error

Attachment: error1.png (image/x-png, text), 11.53 KiB.

[21 Mar 2007 3:20] Jared S
second error

Attachment: error2.png (image/pjpeg, text), 15.88 KiB.

[21 Mar 2007 3:21] Jared S
thrid error

Attachment: error3.png (image/x-png, text), 57.21 KiB.

[21 Mar 2007 13:02] Godofredo Miguel Solorzano
ODBC Error BoxMessage

Attachment: odbc-admin.png (image/x-png, text), 102.13 KiB.

[21 Mar 2007 13:03] Godofredo Miguel Solorzano
Thank you for the bug report.
[28 Mar 2007 18:09] Renato Gontijo
I had the same problem.

I developed an mini-application to create dsn system. I'm using the VB6 and the API:

Public Declare Function SQLConfigDataSource Lib "odbccp32.DLL" (ByVal hwndParent As Long, ByVal fRequest As Long, ByVal lpszDriver As String, ByVal lpszAttributes As String) As Long

When I try to create ODBC (System DSN) on Vista the app crash.

-- begin example VB 6.0

Public Const ODBC_ADD_DSN_SYS = 4

Private vlstrDriver    As String
Private vlstrAtributos As String

vlstrDriver = "MySQL ODBC 3.51 Driver"

vlstrAtributos = "DSN=DbApp" & chr$(0) & _
                 "Description=MyApp Data Source Name" & chr$(0) & _
                 "Database=MyDB" & chr$(0) & _
                 "SERVER=localhost" & chr$(0) & _
                 "Option=4147" & chr$(0)

lngRet = SQLConfigDataSource(vbAPINULL, ODBC_ADD_DSN_SYS, vlstrDriver, vlstrAtributos)

-- end example VB 6.0

the example bellow works on windows vista to create dsn to MS Access and SQL Server, but when I try to create to MySQL using MyODBC 3.51.14 the App crashes like described to other users.
[9 Apr 2007 23:15] Jared S
God dam fix urgently - GA releases should be functional!
[14 Apr 2007 3:45] Godofredo Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=27814 was marked as duplicate
of this one.
[15 Apr 2007 13:39] Tonci Grgin
Bug#27667 was marked as duplicate of this one.
[21 Apr 2007 12:57] Christian Plard
I use the WAMP5 1.7 platform.
Driver 3.51.14 crashes as explained before.
Driver 5.00.11 does not support SQL_CURSOR_DYNAMIC.

Thank you for solving these bugs.
[21 May 2007 21:40] Justin OConnell
I can also verify this issue.  I need to get my application running on vista, and this is preventing that.  Any fixes yet?
[21 May 2007 22:52] Jared S
Yeah, if you made a mistake configuring ODBC then you will need to delete it from regisitry..

\HKEY_LOCAL_MACHINE\Software\ODBC\..
[11 Jun 2007 12:57] Tonci Grgin
Bug#20538 was marked as duplicate of this one.
[26 Jun 2007 16:27] Gable Baldridge
I notice that this bug has not been assigned, yet is critical.  Has work begun on solving it?  Is there a way for me to see the status of this bug?
[26 Jun 2007 23:06] Jared S
I contacted MySQL and they have suggested that there may be upgrading Qt3 to Qt4 to resolve many Vista issues in general.  They also suggested fix early as 3.51.17.  I learnt Qt is some Win32 *NIX cross OS library.  I will add XP to this bug to make it clearer.
[28 Jun 2007 12:22] Tonci Grgin
Jared, can you repeat this problem with latest version?
[29 Jun 2007 23:31] Steven Lawson
It is occuring with 3.51.16 on Vista Ultimate.  Same version has NO problem on the XP Pro box sitting right next to it.
[30 Jun 2007 3:04] Damian Hupfeld
I am having the same issue on Vista (32bit) with both the current 3.51 and 5 ODBCs. I have seen this issue posted in forums all over the net - but no solutions...
[30 Jun 2007 9:04] Damian Hupfeld
Looking at the length this issue has been open I guess I have two choices - I go back to my 4year old XP box or I move to SQL2005 personal edition and ditch mySQL. Neither are good choices...
[30 Jun 2007 14:59] Tonci Grgin
I'll re arise this problem and see what can be done.
[3 Jul 2007 16:21] Sveta Smirnova
Bug is repeatable with current version 3.51.16
[5 Jul 2007 22:44] Peter Krawetzky
Is MySQL going to get a fix for this problem soon?  I am using 3.51.16 and receive the error "ODBC Administrator has stopped working".
[10 Jul 2007 3:51] Jess Balint
fix memory corruption bugs

Attachment: mem_fixes.diff (application/octet-stream, text), 3.04 KiB.

[10 Jul 2007 3:51] Jess Balint
As far as I can see, this clears it up!
[10 Jul 2007 6:22] Gable Baldridge
That's great.  Jess, can you tell me what I am supposed to do with the "mem_fixes.diff" file?
[10 Jul 2007 7:08] Jared S
Wait for x.x.17,  Even if you had VC++ and knowledge I am guessing that applying that .diff file to x.x.16 would complex issue if not breaking compatability.  Ever since release of ODBC x.x.14 the ODBC releases have been steady and rapid.  I would say x.x.17 would be released in couple of weeks when they are satsified that enough changes have been committed.
[10 Jul 2007 16:23] Jess Balint
Patch committed in r557 (will be in 3.51.17 release)
[20 Jul 2007 11:49] MC Brown
A note has been added to the 3.51.17 changelog: 

Fixed a problem where the GUI would crash when configuring or
removing a System or User DSN.