Bug #20538 Cannot add a DSN with Windows Vista Beta 2
Submitted: 19 Jun 2006 14:48 Modified: 11 Jun 2007 12:51
Reporter: Marc Puig Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:3.51.12 OS:Microsoft Windows (Windows Vista Beta 2)
Assigned to: CPU Architecture:Any
Tags: vista

[19 Jun 2006 14:48] Marc Puig
Description:
I know is soon to report bugs on Windows Vista as it is still in Beta version, but here you are...

When adding a DSN in ODBCAD32 (ODBC Data Source Administrator) this errors appears :  COULD NOT WRITE TO THE REGISTRY. COULD NOT REMOVE DSN.

The user is administrator, with full rights. I tried other drivers (SQL Server, access, ...) and all work fine, except the MySql one.

How to repeat:
Try to add a DSN in Windows ODBC Administrator with MySql driver
[20 Jun 2006 8:29] Tonci Grgin
Marc, thanks for your problem report. It is too early for Vista.
Are you using 64bit version?
[20 Jun 2006 9:02] Marc Puig
I am using 32 bit version.

I have found the solution is create the ODBC manually using REGEDIT. After this, the MyODBC works fine. Is just a problem with ODBC Administrator interface.

I attach an example. Just create EXAMPLE.REG with notepad and add these lines :

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\geco]
"Driver"="C:\\Windows\\system32\\myodbc3.dll"
"DATABASE"="mapex"
"DESCRIPTION"="MySQL ODBC 3.51 Driver DSN"
"OPTION"="3"
"PORT"="3306"
"SERVER"="venus"
"UID"="root"

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources]
"geco"="MySQL ODBC 3.51 Driver"
[20 Jun 2006 9:18] Tonci Grgin
Hi Marc. Thanks for workaround you provided.
[21 Jun 2006 11:13] Tonci Grgin
To be properly addressed when Vista is released officially.
[12 Apr 2007 12:26] Sveta Smirnova
Thank you for the report.

UAC in your case is turned on?
[13 Apr 2007 6:45] Sveta Smirnova
Thank you for the report.

I can add 3.51.14 driver/DSN, but I can not remove or change it. It can be part of the same problem.

So bug is verified.
[11 Jun 2007 12:51] Kent Boortz
This is now a duplicate of bug#27315
[11 Jun 2007 12:56] Tonci Grgin
Even though this report is older we decided to make it a duplicate since newer report is against released OS version and new MyODBC.