Bug #25592 wrong reporting for mysql-test-run.pl --mysqld=--binlog-format=...
Submitted: 12 Jan 2007 17:55 Modified: 13 Mar 2007 2:02
Reporter: Andrei Elkin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version:5.1.16-BK, 5.1.15 OS:Linux (Linux)
Assigned to: Magnus Blåudd CPU Architecture:Any

[12 Jan 2007 17:55] Andrei Elkin
Description:
The test script does not parse possible modification of mysqld's --binlog-format
via its --mysqld argument.

E.g 
  ./mysql-test-run.pl --mysqld=--binlog_format=statement
produces
...
MySQL Version 5.1.15
Using binlog format 'mixed'

How to repeat:
see description

Suggested fix:
to parse --mysqld to find out all mysqld options that are changed out of
mysql-test-run.pl's estimations of what should be the default (at least applies to 
binlog_format)
[13 Feb 2007 16:22] Valeriy Kravchuk
Thank you for a bug report. Verified just as described with latest 5.1.16-BK on Linux:

openxs@suse:~/dbs/5.1/mysql-test> ./mysql-test-run.pl --mysqld=--binlog_format=statement
Logging: ./mysql-test-run.pl --mysqld=--binlog_format=statement
MySQL Version 5.1.16
Using binlog format 'mixed'
...
[19 Feb 2007 10:57] Magnus Blåudd
The problem is with underscore. If using --binglog-format=%s statment it will be detected.
[19 Feb 2007 18:06] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/20081

ChangeSet@1.2441, 2007-02-19 12:59:19+01:00, msvensson@pilot.blaudden +1 -0
  Bug#25592 wrong reporting for mysql-test-run.pl --mysqld=--binlog-format=...
[8 Mar 2007 21:17] Timothy Smith
pushed to 5.1.17
[13 Mar 2007 2:02] Paul Dubois
No changelog entry needed.