Bug #25417 "/usr/bin/test" installed from yassl/taocrypt/test
Submitted: 4 Jan 2007 15:28 Modified: 15 Feb 2007 4:45
Reporter: Francesco Riosa Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:5.0, 5.1, 5.2 OS:
Assigned to: Magnus BlÄudd CPU Architecture:Any

[4 Jan 2007 15:28] Francesco Riosa
Description:
compiling falcon from bitkeeper sources install /usr/bin/test (yassl?)
This conflict with important package on linux such as "coreutils"

How to repeat:
make install

Suggested fix:
rename the file
[9 Jan 2007 11:24] Sveta Smirnova
Thank you for the report.

Please provide configure string you use.
[9 Jan 2007 15:21] Francesco Riosa
extracted from "config.log"

./configure \
--prefix=/usr \
--host=x86_64-pc-linux-gnu \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--datadir=/usr/share \
--sysconfdir=/etc \
--localstatedir=/var/lib \
--program-suffix=-5_2_0 \
--libexecdir=/usr/sbin \
--sysconfdir=/etc/mysql-5_2_0 \
--localstatedir=/var/lib/mysql-5_2_0 \
--sharedstatedir=/usr/share/mysql-5_2_0 \
--libdir=/usr/lib64/mysql-5_2_0 \
--includedir=/usr/include/mysql-5_2_0 \
--with-low-memory \
--with-client-ldflags=-lstdc++ \
--enable-thread-safe-client \
--without-docs \
--without-big-tables \
--enable-local-infile \
--with-extra-charsets=all \
--with-mysqld-user=mysql \
--with-server \
--with-unix-socket-path=/var/run/mysqld/mysqld.sock \
--without-libwrap \
--enable-shared \
--enable-static \
--without-debug \
--with-charset=utf8 \
--with-collation=utf8_general_ci \
--without-embedded-privilege-control \
--without-embedded-server \
--with-ssl \
--enable-assembler \
--with-geometry \
--with-readline \
--with-row-based-replication \
--with-zlib=/usr/lib64 \
--without-pstack \
--with-plugins=csv,myisam,myisammrg,heap,falcon \
--build=x86_64-pc-linux-gnu
[10 Jan 2007 9:42] Sveta Smirnova
You installs MySQL in unusual place instead of default /usr/local or "dedicated" directory. So it is not a bug. I'll reclassify it as "Feature request"
[10 Jan 2007 17:04] Jim Winstead
While this may not be a common problem, it can be very bad when it happens. The problem is with YaSSL, so I'm going ahead and assigning it to the developer who handles bugs there. All that needs to happen is for the 'test' program to be renamed something more appropriate, or not installed.
[29 Jan 2007 17:46] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/18972

ChangeSet@1.2394, 2007-01-29 18:46:06+01:00, msvensson@pilot.mysql.com +2 -0
  Bug#25417 "/usr/bin/test" installed from yassl/taocrypt/test
   - It's good to build the test programs for yaSSL to check for undefined
     symbols etc but they should not be installed by "make install"
[14 Feb 2007 15:11] Chad MILLER
Available in 5.0.36 and 5.1.16-beta.
[15 Feb 2007 4:45] Paul Dubois
Noted in 5.0.36, 5.1.16 changelogs.

A yaSSL program named test was installed, causing conflicts with the
test system utility. It is no longer installed.