Bug #24780 Make /etc/mysql directory configurable
Submitted: 3 Dec 2006 21:23 Modified: 13 Feb 2007 19:16
Reporter: Christian Hammers (Silver Quality Contributor) (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.0.27 OS:Linux (Debian GNU/Linux Sid)
Assigned to: Daniel Fischer CPU Architecture:Any
Tags: bfsm_2007_01_18

[3 Dec 2006 21:23] Christian Hammers
Description:
Hello

As most distributions use something like /etc/mysql/ it would be handy if ./configure would provide --confdir or similar which would actually be used by all programs and scripts, too.

Today I stumbled on mysqld_multi which has /etc/my.cnf hardcoded and therefore
does not find /etc/mysql/my.cnf on Debian machines.

bye,

-christian-

How to repeat:
...

Suggested fix:
...
[4 Dec 2006 8:31] Sveta Smirnova
Thank you for the report.

But this feature is already implemented. Run ./configure --help for details.
[4 Dec 2006 8:47] Christian Hammers
I only find --sysconfdir which defaults to $PREFIX/etc, do you mean that?

If you do, then please retitle+reopen this bugreport because scripts/mysqld_multi.sh does not use it but has /etc/my.cnf hardcoded in it.

bye,

-christian-
[4 Dec 2006 9:09] Sveta Smirnova
Thank you for the clarification.

Verified as described in last comment.
[7 Dec 2006 14:02] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/16587

ChangeSet@1.2564, 2006-12-07 15:02:32+01:00, df@kahlann.erinye.com +3 -0
  BUG#24780 use --sysconfdir in scripts
[9 Jan 2007 8:33] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/17761

ChangeSet@1.2593, 2007-01-09 09:32:56+01:00, df@kahlann.erinye.com +2 -0
  BUG#24780 workaround for broken installations that depend on using /etc, but were configured differently
[9 Jan 2007 16:20] Daniel Fischer
Bug#25498 was marked a duplicate of this bug, as it was introduced by the first patch to fix this bug, and should be fixed by the second.

Unfortunately, our own builds are not configured to use /etc for configuration files, so using the configured directory only broke mysqld_multi for users who relied on this.
[24 Jan 2007 15:59] Daniel Fischer
Pushed to 5.1.15.
[24 Jan 2007 18:38] Joerg Bruehe
Pushed to 5.0.36.
[24 Jan 2007 18:46] Joerg Bruehe
Fix is also in 4.1.23.
[13 Feb 2007 19:16] Paul Dubois
Noted in 4.1.23, 5.0.36, 5.1.15 changelogs.

mysqld_multi and mysqlaccess looked for option files in /etc even if
the --sysconfdir option for configure had been given to specify a
different directory.