Bug #24675 Closing ODBC window after System DSN edit crashes comp
Submitted: 29 Nov 2006 1:59 Modified: 13 Dec 2006 1:35
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.0.9 BETA OS:Microsoft Windows (WinXP)
Assigned to: Jess Balint CPU Architecture:Any
Tags: close, crash, ODBC

[29 Nov 2006 1:59] Jared S
Description:
Hi,

This is a fairly simple and straightforward bug.  After installing ODBC connector 5.0.2 BETA I simply add a System DSN and after closing the "ODBC Database Administrator" dialog, windows crashes.

How to repeat:
1. install odbc connector 5.0.2 beta
2. add new system dsn odbc
3. close 'ODBC Database Administrator'

-whole thing come down in flames

Suggested fix:
ensure users can edit odbc setting from windows, this include closing of odbc form after settings successfuly committed.
[29 Nov 2006 2:07] Jared S
Screenshot of the error

Attachment: odbc-error.PNG (image/x-png, text), 16.55 KiB.

[29 Nov 2006 2:26] Valeriy Kravchuk
Thank you for a problem report. Please, try to repeat with a newer version, 5.00.09-beta, and inform about the results.
[29 Nov 2006 3:33] Jared S
Yes I was using 5.0.9.  I have now updated bug, cause the version was wrong.
[29 Nov 2006 7:52] Tonci Grgin
Hi Jared and thanks for your report. We are aware of this and are working on a fix.
[6 Dec 2006 5:37] Jess Balint
bug#24836 was marked as a duplicate of this
http://bugs.mysql.com/bug.php?id=24836
[7 Dec 2006 23:30] Jess Balint
Committed as rev711.

The issue here is that there is a cache that initialized and free'd when the setup DLL is unloaded. Since QApplication is static, that is free'd when the compilation unit is unloaded. The order that this was happening was that the cache was being free'd first, but the QApplication expected to handle it and tried to free it again.

I reduced the scope of the QApplication to only when the GUI is shown.
[13 Dec 2006 1:35] Jess Balint
Fix released in 5.00.10 beta.