Bug #24054 ODBC Connector crashes on executing any select statement using ADO
Submitted: 7 Nov 2006 17:31 Modified: 20 Nov 2006 11:07
Reporter: Marek Srom Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.0.6 OS:Microsoft Windows (Win XP SP2)
Assigned to: CPU Architecture:Any
Tags: ODBC5-RC

[7 Nov 2006 17:31] Marek Srom
Description:
DB 5.1 (5.0 also) - using ADO / MDAC 2.8 - execute "select * from any table" => crash of visual studio - error in module myodbcdriver5.dll

How to repeat:
code in VB:

  Dim conn As New ADODB.Connection
  conn.Open "DRIVER={MySQL Connector/ODBC v5 Driver};SERVER=localhost;DATABASE=mydb;UID=root;PWD=xxx; OPTION=3;"
  conn.Execute "create table aaa(x int)"
  Set rs = conn.Execute("select * from aaa") '==CRASH
  rs.Close
  Set rs = Nothing
  conn.Close
  Set conn = Nothing
[8 Nov 2006 15:04] Tonci Grgin
Hi Marek and thanks for your report.
I am unable to crash VS nor am I able to trace problem to MyODBC 5 driver but the problem exists: Exception is rised "at ADODB.ConnectionClass.Execute(String CommandText, Object& RecordsAffected, Int32 Options)" as SQLDescribeColW() fails on Integer column...

I would like if you can provide more info on your environment regarding VS crahs...
[10 Nov 2006 17:01] Marek Srom
VB Project

Attachment: mysql.zip (application/x-zip-compressed, text), 5.57 KiB.

[10 Nov 2006 17:06] Marek Srom
In files is project and compiled exe - to the textbox eneter root pwd.
I have Visual Studio 6.0 SP6, Win XP SP2, all MS updates, ODBC 5.0.6, DB last 5.1 beta. I had earlier versions before, tried to uninstall all and install newly but problem persist. ADO is version 2.8, problem is the same when calling from ASP page on IIS - reports unspecified error. Tell me what more u want to know. I can try to install it on another machine if the problem persits.
[13 Nov 2006 7:28] Tonci Grgin
Hi Marek. As you can see from my first answer, I am aware of this problem for some time now... Our connecotr/ODBC team is working on it. Can you please try with 5.00.07?

As for test case, VS2005 has problems opening it... Next time, please post *all* of project files (and not the executable).
[13 Nov 2006 9:42] Marek Srom
Reproduce crash

Attachment: test.vbs (application/octet-stream, text), 389 bytes.

[13 Nov 2006 9:45] Marek Srom
Hi,
i tested it with 5.0.07 ODBC connector, tested on another machine w2k where mysql has never been - the same result. I added simple vbs script - just edit for a password change and run.
[13 Nov 2006 11:15] Tonci Grgin
Hi Marek. Here we have two problems:
1) Provider=MSDASQL.1; -> doesn't work
Const cConnectionString= "DRIVER={MySQL Connector/ODBC v5};SERVER=localhost;DATABASE=mysql;UID=root;PWD=; OPTION=3;" -> works
'Const cConnectionString= "Provider=MSDASQL.1;Persist Security Info=False;Extended Properties=Provider=MySQLProv;DRIVER={MySQL connector/ODBC v5};SERVER=localhost;DATABASE=test;USER=root;PASSWORD="';OPTION=16387;Initial Catalog=" -> doesn't work

2) I'm not sure but it seems that either/both SQLTables(W) and SQLColumns(W) are failing

See attached files for details.
[13 Nov 2006 11:16] Tonci Grgin
Test case

Attachment: Bug24054.vbs (application/octet-stream, text), 2.20 KiB.

[13 Nov 2006 11:17] Tonci Grgin
DM trace

Attachment: Bug-24065-SQL.zip (application/x-zip-compressed, text), 2.48 KiB.

[13 Nov 2006 11:18] Tonci Grgin
MyODBC5 trace

Attachment: Bug-24065-MYODBC5.zip (application/x-zip-compressed, text), 5.67 KiB.

[13 Nov 2006 11:23] Tonci Grgin
I forgot to mention, the error thrown (80004005) is thrown for almost everything that goes wrong so it doesn't help at all...
Attached logs are tagged with wrong bug nr, should be 24054.
[20 Nov 2006 11:07] Tonci Grgin
This is a duplicate of Bug#17604.