Bug #23984 mysqltest on HP-UX
Submitted: 5 Nov 2006 9:23 Modified: 9 Dec 2006 18:18
Reporter: Magnus Blåudd Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version:5.1 OS:HP/UX (hpux11)
Assigned to: Magnus Blåudd CPU Architecture:Any

[5 Nov 2006 9:23] Magnus Blåudd
Description:
When running on hpux11 in PushBuild, mysqltest crashes.

alias                          [ fail ]

ERROR: mysqltest returned unexpected code 134, it has probably crashed

Stopping All Servers
Shutting-down Instance Manager
Restoring snapshot of databases
Resuming Tests

How to repeat:
PushBuild test on hpux11
[8 Nov 2006 22:18] Magnus Blåudd
Most likely caused by using locally installed charset files. It magically works in 5.0 but someting must have changed for 5.1
Wrote a patch that makes mysqltest set MYSQL_SET_CHARSET_DIR before connecting to mysqld.
[13 Nov 2006 12:36] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/15223

ChangeSet@1.2353, 2006-11-13 13:36:07+01:00, msvensson@neptunus.(none) +1 -0
  Bug#23984 mysqltest on HP-UX
  - Cleanup the Makefile for client
  - Don't link mysqltest with mysys as it's been compiled with different flags.
[13 Nov 2006 15:41] Magnus Blåudd
Pushed to 5.1-maint
[9 Dec 2006 18:17] Paul Dubois
Noted in 5.1.15 changelog.

On HP-UX, mysqltest (non-thread-safe) crashed due to being linked
against a thread-safe libmysys library.