Bug #23973 --without-server builds server
Submitted: 4 Nov 2006 10:44 Modified: 26 Jan 2007 2:51
Reporter: Mark Johnson (Basic Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.29-BK, 5.0.27 OS:Linux (linux, Solaris)
Assigned to: Kent Boortz CPU Architecture:Any

[4 Nov 2006 10:44] Mark Johnson
Description:
After configuring with --without-server, make builds the mysqld binary.  Section 4.1 of the manual indicates that this is the MySql server that the --without-server option to configure is supposed to NOT build.

How to repeat:
./configure --prefix=/usr --libdir=/usr/lib --without-server --enable-thread-safe-client
make
make install DESTDIR=`pwd`/tmp

Observe that the directory `pwd`/tmp/usr/libexec contains the mysqld server program.  Checking `pwd`/tmp/usr/bin finds other programs that don't seem to make sense for a client-only install.
[5 Nov 2006 12:18] Valeriy Kravchuk
Thank you for a bug report. Verified just as described, with 5.0.29-BK, also on Solaris:

cd work/mysql-5.0/
export CC=cc
export LD_LIBRARY_PATH=/usr/local/lib:/usr/sfw/lib
export PATH=/export/home/mysqldev/sol10-amd64-a/bin:/usr/local/bin:/usr
/bin:/bin:/usr/sbin:/sbin:/usr/ccs/bin:/opt/SUNWspro/bin
export CXX=CC
./configure --prefix=/users/vkravchuk/dbs/5.0-sol10 --without-server --enable-thread-safe-client
make clean
make
make install
cd ~/dbs/5.0-sol10

And we do have mysqld there:

-bash-3.00$ ls -l libexec/my*
-rwxr-xr-x   1 vkravchuk vkravchuk 6666400 Nov  5 13:12 libexec/mysqld
[7 Dec 2006 20:24] Sveta Smirnova
Bug #24890 has been marked as duplicate of this one
[1 Jan 2007 6:23] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/17495

ChangeSet@1.2588, 2007-01-01 07:22:57+01:00, kent@mysql.com +1 -0
  configure.in:
    Don't build server when configured --without-server (bug#23973)
[25 Jan 2007 19:02] Joerg Bruehe
The patch was pushed into 5.1.15 on Jan 11 already :-(
It is in 5.0.34 and will be in 4.1.23.
[26 Jan 2007 2:51] Paul Dubois
Noted in 4.1.23, 5.0.34, 5.1.15 changelogs.

The server was built even when configure was run with the
--without-server option.
[1 Dec 2007 20:44] Anthony Wright
This bug does not seem to be fixed in 5.0.45.

I get the server files when I build with '--without-server --enabled-thread-safe-client', and when I look at configure.in, the patch has not been applied.
[2 Dec 2007 9:13] Sveta Smirnova
Bug #32898 about very same problem marked as verified packaging bug
[4 Dec 2007 15:16] Kent Boortz
As noted in bug#32898, for some unknown
reason this patch didn't make it into the
community releases, and was missing in both
5.0.45 and 5.0.51.