Bug #23840 MySQL Connector/ODBC 5.0.5-beta-win32 is not working good at all
Submitted: 1 Nov 2006 14:22 Modified: 3 Nov 2006 11:19
Reporter: Ross Ivantsov Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.0.5-beta-win32 OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[1 Nov 2006 14:22] Ross Ivantsov
Description:
I use MySQL Server 5.0.19-nt, ODBC connector 5.0.5-beta-win32 (latest) and Access 2003

When i try to link tables in Access using the ODBC data source created with this driver, i get a table list, but when i select a table in the list and want to link it, an error is thrown:

Rezerved error (-7748); Message Text for this error is not available.

or (when the table has an underscore _ in its name):

Object is not found by MS Jet bla-bla.

The same message when you want to link View (introduced from MySQL 5.0).

How to repeat:
Just take Access 2003, do "install 0" and then try to link tables

Suggested fix:
Guys, if you call it a beta version, you are seriously mistaken. Sorry, it may sound rude, but its a cr.p.

Also i would like to say some words concerning expectations. Currently i use ODBC 3.51 for my applications. Each table has a primary key (ID) and a timestamp field - then it works good, without stupid #deleted problems.

The only problem is Unicode. Currently most MySQL databases use character set utf8 and contain multilingual strings. In Access it often shows as ?????????? signs. I do SET NAMES cp1251 (or whatever else), but it only works ok for 2 languages (English and your language). 

TRUE UNICODE SUPPORT - that's what is the main todo!!! It stops MySQL from integration with MS Office applications. Not the links between tables - it may be done with other software like EMS, MySQLYog etc.

Please, implement UNICODE!!!
[3 Nov 2006 11:19] Tonci Grgin
Hi Ross and let me say I agree with you. We are working hard on unicode support.

Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Explanation: This is the duplicate of BUG#23549 which has been verified.