Bug #23581 myODBC in Blue Dragon
Submitted: 24 Oct 2006 11:27 Modified: 25 Oct 2006 4:41
Reporter: Andy Kartika Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.12 OS:Microsoft Windows (Windows 2003 Server Standard)
Assigned to: CPU Architecture:Any
Tags: Blue Dragon, Cold Fusion, MyODBC

[24 Oct 2006 11:27] Andy Kartika
Description:
Hi,

My website is built using Cold Fusion and MySQL 5.0 as the database. The website is deployed in Windows 2003 Server Standard Edition with the Blue Dragon Server Free edition. For the database connection between the Cold Fusion page and the MySQL 5.0 database, we use a Data Source which is using MySQL Connector 3.51.12.

When we try to execute the page which retrieve data from database using stored procedure, it gives me an error message that the Data Source does not support Stored Procedure.

Then, we decided to upgrade the connector with the latest version, i.e. mySQL 5.0. However, the connector onlny populates data source as User DSN. The user DSN will not be retrieved by the Blue Dragon Server, as it requires a System DSN, not User DSN.

Please help!!! I have been stuck with this problem for almost a week.

How to repeat:
1. Install myODBC 3.51.12
2. Add Data Source to the Blue Dragon Server
3. Execute a Cold Fusion page which executes a mySQL 5.0 stored procedure.

Suggested fix:
Either enable the mySQL 5.0 as the system DSN or fix the mySQL 3.51.12 to enable stored procedure execution.
[24 Oct 2006 13:51] Tonci Grgin
Hi Andy and thanks for your problem report. Here you actually reported two of them:
1) enable the connector/ODBC 5.0 to create system DSN
2) fix the mySQL 3.51.12 to enable stored procedure execution

1) For this part, your report is duplicate of BUG#20962. The patch for this problem is already pushed to relevant source trees of connector/ODBC 5

2) 3.51.13 has SP support and should be released soon, but I can't tell you exactly when. So watch out for announcement.
[25 Oct 2006 4:41] Andy Kartika
How do I receive the patch for bug BUG#20962?