Bug #20962 Datasource created as User DSN
Submitted: 11 Jul 2006 7:42 Modified: 20 Nov 2006 16:02
Reporter: Frank Maas (Basic Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.0.4, 5.0.5 OS:Microsoft Windows (Win2003)
Assigned to: Jess Balint CPU Architecture:Any

[11 Jul 2006 7:42] Frank Maas
Description:
If you press 'Add' in the System DSN tab of the ODBC manager and create the MySQL datasource it is eventually created as User DSN.

How to repeat:
Open ODBC manager
Go to System DSN tab
Press Add
Choose MySQL Connector...v5
Fill in details
Press OK
See for yourself (I hope)

Suggested fix:
N/A
[11 Jul 2006 14:14] Miguel Solorzano
Thank you for the bug report. I was unable to create a System DSN only
as User DSN.
[17 Aug 2006 2:24] [ name withheld ]
Is there any way to create System DSN for ODBC5?
(apart from using ODBC driver manager, because its not able to create System DSN for ODBC5 only User DSN - this bug).
[17 Oct 2006 15:33] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=23375 was marked as duplicate of
this one.
[17 Oct 2006 15:41] Sebastien Caisse
Oops, Indeed 23375 is a dup: I looked into the bug database and given the blurb in the 5.0.5 about the addition of the UI in the installation I didn't look into 5.0.4 bugs before reporting.

Sorry about that.

In light of that though, here's the simplest thing to do I can think of right now to add it to the System list:
- Export the HKCU/Software/ODBC/ODBC.INI/<Your DSN> into a .reg file
- Edit the .reg file to change HKCU to HKLM 
- "register" it.
- Then you also re-add the key HKLM/Software/ODBC/ODBC.INI/ODBC Data Sources named as <Your DSN> with the "MySQL Connector/ODBC v5 Driver" REG_SZ string value.
[17 Oct 2006 15:53] Frank Maas
Added 5.0.5 in version tag based on bug #23375.
[23 Oct 2006 21:08] Jess Balint
was hardcoded to "both" (first try user, then system) in ConfigDSNW.
[20 Nov 2006 16:02] Mark Matthews
Fixed in 5.0.7.