Bug #23425 server inst fails on Windows: 'Access denied for user ''@@BITROCK_MYSQ (br 1727)
Submitted: 18 Oct 2006 14:53 Modified: 21 Oct 2006 23:49
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S1 (Critical)
Version:0.7.4 OS:Microsoft Windows (Windows XP)
Assigned to: Keith Russell CPU Architecture:Any

[18 Oct 2006 14:53] Carsten Segieth
Description:
trying to install the server on Windows fails. A popup message box appears (see file attachment):

Here the end of the installer.log:

...
Initializing Database. This may take some time. (1/4)
Executing C:/PROGRA~1/MySQL/Network/mysql/bin/mysqld.exe
Script output:

Initializing Database. This may take some time. (2/4)
Installing Services. This may take a minute. (3/4)
Executing C:/PROGRA~1/MySQL/Network/mysqlnetworkaux.bat
Error running C:/PROGRA~1/MySQL/Network/mysqlnetworkaux.bat  : ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
C:/PROGRA~1/MySQL/Network/mysql/bin/mysqladmin.exe: connect to server at 'localhost' failed
error: 'Access denied for user ''@@BITROCK_MYSQL'@'localhost' (using password: YES)'

How to repeat:
simpl run the installer on Windows
[18 Oct 2006 14:55] Carsten Segieth
message box with error message

Attachment: bug#181.jpg (image/jpeg, text), 25.53 KiB.

[18 Oct 2006 16:18] Carsten Segieth
- may this is from my non-standard settings (password/port)
- may be it's from a not-fixed bug#23286 - Server inst does not update merlin.xml correctly (br 1685)
- I'll add a zip with the log, the config and the 2 .xml files
[18 Oct 2006 16:19] Carsten Segieth
zip containing bitrock_installer.log, the config report and the 2 .xml files

Attachment: bug#23425.zip (application/zip, text), 25.26 KiB.

[18 Oct 2006 16:25] Carsten Segieth
a similar problem with a bit different error message has been closed as duplicate of this bug here: bug#23431
[20 Oct 2006 3:48] Keith Russell
Bitrock reports solved in builds >= 7.6
[21 Oct 2006 23:49] Bill Weber
Verified fixed in build 7.9.