Bug #19300 Partitions: crash if create index
Submitted: 24 Apr 2006 14:51 Modified: 8 May 2006 11:57
Reporter: Peter Gulutzan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Partitions Severity:S3 (Non-critical)
Version:5.1.10-beta-debug OS:Linux (SUSE 10.0 / 64-bit)
Assigned to: Mikael Ronström CPU Architecture:Any

[24 Apr 2006 14:51] Peter Gulutzan
Description:
I create an InnoDB table with partition by range.
I insert 10,000 rows.
I try to create an index.
Crash.

How to repeat:
mysql> create table t1 (s1 int, s2 int) engine=innodb partition by range (s1) (partition p1 values less than (0), partition p2 values less than maxvalue);
Query OK, 0 rows affected (0.04 sec)

mysql> delimiter //
mysql> create procedure p1 () begin declare v1 int default 0; while v < 10000 do insert into t1 values (v,v); set v = v + 1; end while; end//
ERROR 1193 (HY000): Unknown system variable 'v'
mysql> create procedure p1 () begin declare v int default 0; while v < 10000 do insert into t1 values (v,v); set v = v + 1; end while; end//
Query OK, 0 rows affected (0.05 sec)

mysql> call p1()//
Query OK, 1 row affected (6.72 sec)

mysql> create index t1i on t1 (s1)//
ERROR 2013 (HY000): Lost connection to MySQL server during query
[24 Apr 2006 15:00] Miguel Solorzano
Thank you for the bug report. Verified on Suse 10.0/32-bit:

060425 11:57:49 [Note] /home/miguel/dbs/5.1/libexec/mysqld: ready for connections.
Version: '5.1.10-beta-debug'  socket: '/tmp/mysql.sock'  port: 3306  Source distribution
[New Thread 1118682032 (LWP 6121)]
[Thread 1118682032 (zombie) exited]
[New Thread 1118682032 (LWP 6123)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1118682032 (LWP 6123)]
0x0840b98d in ha_partition::min_of_the_max_uint (this=0x92c4658, operator_func={__pfn = 0x1b1, __delta = 0}) at ha_partition.cc:5206
5206      uint min_of_the_max= ((*m_file)->*operator_func)();
(gdb)
[8 May 2006 11:57] Mikael Ronström
Duplicate of Bug #19140 which has a bug fix in the works