Bug #19140 Partitions: crash if memory and index
Submitted: 17 Apr 2006 14:36 Modified: 22 May 2006 14:24
Reporter: Peter Gulutzan Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Partitions Severity:S3 (Non-critical)
Version:5.1.10-beta-debug OS:Linux (SUSE 10.0 / 64-bit)
Assigned to: Mikael Ronström CPU Architecture:Any

[17 Apr 2006 14:36] Peter Gulutzan
Description:
I create a table with ENGINE=MEMORY and PARTITION BY KEY.
I Insert a row.
I try to create an index.
Crash.

How to repeat:
mysql> create table tz (s1 int) engine=memory partition by key(s1);
Query OK, 0 rows affected (0.03 sec)

mysql> insert into tz values (1);
Query OK, 1 row affected (0.01 sec)

mysql> create index itz on tz (s1);
ERROR 2013 (HY000): Lost connection to MySQL server during query
[17 Apr 2006 14:44] Miguel Solorzano
Thank you for the bug report.

Version: '5.1.10-beta-debug'  socket: '/tmp/mysql.sock'  port: 3306  Source distribution
[New Thread 1118682032 (LWP 9645)]
[Thread 1118682032 (zombie) exited]
[New Thread 1118682032 (LWP 9647)]
[Thread 1118682032 (zombie) exited]
[New Thread 1118682032 (LWP 9649)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1118682032 (LWP 9649)]
0x0840b679 in ha_partition::min_of_the_max_uint (this=0x92c56e8, operator_func={__pfn = 0x1b1, __delta = 0}) at ha_partition.cc:5206
5206      uint min_of_the_max= ((*m_file)->*operator_func)();
(gdb)
[8 May 2006 11:55] Mikael Ronström
Made use of thd->lex->create_info in a function where I should have used
pointer to create_info passed as parameter, made the code take a wrong turn.
Easy fix.
Most likely the cause also of #19300, will mark this as duplicate when this has
been verified.
Will have a patch pending very soon.
[20 May 2006 15:53] Mikael Ronström
Patch will appear in 5.1.11
[22 May 2006 14:24] Jon Stephens
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Documented bugfix in 5.1.11 changelog; closed.