Bug #18431 Down arrow doesn't return to current input
Submitted: 22 Mar 2006 18:56 Modified: 9 Jan 2008 14:45
Reporter: Kolbe Kegel Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.0,5.1, 5.2 BK OS:Linux (Linux)
Assigned to: Daniel Fischer CPU Architecture:Any
Tags: bfsm_2007_10_18

[22 Mar 2006 18:56] Kolbe Kegel
Description:
Using the down arrow fails to return to the current line of work if you have used the up arrow to access more than 1 history entry.

How to repeat:
* Open mysql command line client
* Enter a few commands
* Enter part of a command, do not execute
* Press up arrow several times
* Press down arrow several times

It is not possible to return to the line you were entering before hitting the up arrow to access the history.

Suggested fix:
It should always be possible to return to an incomplete line of work when using the mysql command line client.
[22 Mar 2006 19:19] Miles Crawford
I can confirm this bug on the 5.0.19 build for linux x86.  This is frustrating as looking back in the history to  reference an earlier query while constructing a new one is common.
[8 May 2006 22:42] Morgan Tocker
Testcase:

1) connect to a server with the mysql command line client
2) type "select 1;" enter
3) type "select 2;" enter
4) type "select 3;" enter
5) up-arrow once (select 3), twice (select 2), three times (select 1)
6) down-arrow once (select 2), twice (select 3), three times (select 2)

On step 6 the third down arrow should have been a blank line not "select 2".
[3 Sep 2007 17:26] Sveta Smirnova
Bug is repeatable with today 5.2-BK sources as well.
[5 Oct 2007 10:50] Magnus BlÄudd
Raising priority since this affects a customer and has a related support issue
[10 Oct 2007 7:11] Bryce Kahle
This appears to be due to MySQL using an outdated version of readline. The source for 5.1.22-rc uses readline 5.0. This bug was fixed in 5.1. See bugfix 1b in http://tiswww.case.edu/php/chet/readline/CHANGES between 5.0 and 5.1.
[19 Nov 2007 13:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/38057

ChangeSet@1.2555, 2007-11-19 14:38:08+01:00, df@pippilotta.erinye.com +43 -0
  Update readline to version 5.2. This fixes bug#18431.
[20 Nov 2007 10:10] Daniel Fischer
Queued in -build.
[21 Nov 2007 18:52] Bugs System
Pushed into 5.0.54
[21 Nov 2007 18:54] Bugs System
Pushed into 5.1.23-rc
[21 Nov 2007 18:54] Bugs System
Pushed into 6.0.4-alpha
[3 Dec 2007 9:57] MC Brown
A note has been added to the 5.0.54, 5.1.23 and 6.0.4 changelog: 

The readline library has been updated to version 5.2. This addresses issues in the mysql client where history and editing within the client would fail to work as expected.
[7 Dec 2007 11:34] Daniel Fischer
This is actually in 5.0.52, not in 5.0.54.
[9 Jan 2008 14:45] Paul Dubois
Moved 5.0.x changelog entry from 5.0.54 to 5.0.52.