Bug #16778 ODBC connect is not possible
Submitted: 25 Jan 2006 13:04 Modified: 5 Feb 2007 18:23
Reporter: Thomas Mueller Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.12 OS:Microsoft Windows (Windows 2003 Server)
Assigned to: CPU Architecture:Any

[25 Jan 2006 13:04] Thomas Mueller
Description:
I'm trying to use mySQL Community Edition 5.0.18 with mySQL Connector/ODBC 3.51.12. Configuring SYSTEM DSN, connection is O.K. (tested).
But when I try to link the database tables with Access2003, I get the reply
"[MySQL][ODBC 3.51 Driver]User cancelled."

How to repeat:
Try to link mySQL 5.0.18 to mySQL Connector/ODBC 3.51.12
[25 Jan 2006 13:47] Miguel Solorzano
I was unable to repeat this issue. Can you show the create table definition
which are you trying to link?

Thanks in advance.
[25 Jan 2006 17:34] Thomas Mueller
Here are some screenshots desribing the problem

Attachment: ODBC_failure1.zip (application/x-zip-compressed, text), 200.82 KiB.

[26 Jan 2006 9:40] Thomas Mueller
I added screensshots yesterday, please contact me, if some information is missing yet.
[26 Jan 2006 15:59] Miguel Solorzano
Thank you for the feedback. I was able to repeat with your complementary
information:

1- When creating the system DSN the user and password are empty.
2- When pop up the Connector setup screen inside Access and after
    to fill the user and password text boxes + ok, the message error reported
    happens and the table can't be linked.
[6 Jun 2006 13:27] eric wion
I have this same problem.  Has there been any resolution to this?  Thank you
[4 Nov 2006 2:01] Pedro Marmol
I posted the same probñem before finding this bug report.
The connector with the user and password stored, works fine. If you erase them, when trying to link or open a linked table, the connector dialog appears, with both fields empty, of course. You may fill them but it doesn't work. Is like the connector don't pass the input values, and the connection is made with empty values and fails. I tried blanking only one of both fields at a time, with same results.
Both fields must be optional so user have to type them when trying to access, otherwise everyone may access using stored values.
[8 Nov 2006 19:49] Steve Johnson
Same as bug 16640? If you store the user/password values and go to Advanced/Flags 2, then check "Don't Prompt Upon Connect" then the connection works.
[9 Nov 2006 3:08] Pedro Marmol
The prerelease of v3.51.13 solved the problem.

Go to bug #15118 (same as this) for details.
[5 Feb 2007 18:23] Bogdan Degtyariov
Fixed in source repository. MyODBC 3.51.13 will have this bug fixed