Bug #16008 User Administrator->Resources->max_user_connections is no use
Submitted: 27 Dec 2005 9:48 Modified: 1 Aug 2006 11:06
Reporter: ming lu Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.1.6 OS:Microsoft Windows (windows2000 server)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any
Tags: User Management

[27 Dec 2005 9:48] ming lu
Description:
    Run the administrator and create a new user, choose the  "Resources" tab. There is a new editbox named "max_user_connections ". Its explanation is same  as the "max_connections", and the connection number is no use.
    Is it a duplicate setting with the  "max_connections"?

How to repeat:
see the description
[27 Dec 2005 9:50] ming lu
the bug picture

Attachment: max_user_connection.jpg (image/jpeg, text), 81.31 KiB.

[27 Dec 2005 10:51] Aleksey Kishkin
Thank you for taking the time to report a problem.  Unfortunately
you are not using a current version of the product your reported a
problem with -- the problem might already be fixed. Please download
a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions,
please change the version on this bug report to the version you
tested and change the status back to "Open".  Again, thank you for
your continued support of MySQL.
[27 Dec 2005 10:53] Aleksey Kishkin
I checked mysql admin 1.1.4 and there is one only 'number of connections to the server the user can open in an hour'
[28 Dec 2005 3:18] ming lu
Please note that the problem is about "max_user_connections".
Is the "max_user_connections" same as the "max_connections" ?
The "max_user_connections" can not be seen in normal circumstance.You should do the test according to my test steps.
[28 Dec 2005 3:22] ming lu
I find the same problem in mysql-administrator V1.1.5
[28 Dec 2005 15:05] Aleksey Kishkin
can't reproduce

Attachment: bug16008.PNG (image/png, text), 112.08 KiB.

[28 Dec 2005 15:09] Aleksey Kishkin
finally got it

Attachment: bug16008_newuser.PNG (image/png, text), 55.39 KiB.

[28 Dec 2005 15:14] Aleksey Kishkin
It happens for newly created user only.

run mysql-administrator - user administration - new user - tab resources.

I would say if I enter user name, press apply and return to resources tab, it looks wrongly (attached file bug16008_wrong.png) (some field are semi-hidden by frame)
[28 Dec 2005 15:14] Aleksey Kishkin
wrong user resource tab after creating new user

Attachment: bug16008_wrong.PNG (image/png, text), 53.95 KiB.

[24 Jul 2006 8:03] Michael G. Zinner
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://www.mysql.com/doc/en/Installing_source_tree.html