Bug #15642 MyODBC 5.0 Alpha doesn't work
Submitted: 9 Dec 2005 17:50 Modified: 9 Dec 2005 18:55
Reporter: Yuriy Pavlyutkin Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:MyODBC 5.0 Alpha OS:Microsoft Windows (Win 2000)
Assigned to: CPU Architecture:Any

[9 Dec 2005 17:50] Yuriy Pavlyutkin
Description:
MySQL server version 5.0.15 (mysqld-nt), host=localhost
Default server characterset is latin1
MyODBC 3.51.11-2 is installed too and works well.

 1. When MyODBC 5.0.0 installed from *.msi version in the %systemroot%/system32, installer makes .dll and .exe files named for DOS-style: 
MyODBC~1.dll
MyODBC~2.dll
MyODBC~1.exe
 I think, there is by error reason, but not kept in the mind.

 2. When connection made using "Administration -> Data sources (ODBC)" system panel, and correct host-port-user-password info is inputed, connection test is successful, but datebase selection field produce list of "abracadabra" instead list of accessible databases for selection default (I think problem caused error in using utf8 characterset for this field). When I input right database name for this field by typing, connection test is successful.

 3. When I make ODBC 5 DSN and try to connect to it from MS Access 2000, error popups instead accessible table list: 
"Reserved error (-7701). Message for this error is absent."
Error repeatable for two different computers where MyODBC installed and user makes connection to localhost DB.

 4. I don't like IE-browser and use Mozilla FireFox 1.0.3 instead. When I press button "Help" in the Connecor/ODBC window I have error message like "File iexplore.exe not found" (I have deleted IE. Or, for security reason iexplore.exe file can be disabled by some way).

 5. I can't find any documentation about MyODBC 5.0. Help button into MyODBC 5.0 Connecor/ODBC window leads to help for MyODBC 3.51.

How to repeat:
 Install *.msi version MyODBC 5 on Windows 2000 workstation, made new MyODBC5 User-DSN or System-DSN, and try to link or Import data from MS-Access 2000 using this connection.

Suggested fix:
 4. Use default browser instead IE: "Start http://dev.mysql.com/doc/refman/5.0/en/odbc-connector.html" instead "c:/Program Files/..../iexplore.exe http://dev.mysql.com/doc/refman/5.0/en/odbc-connector.html"
[9 Dec 2005 18:55] Miguel Solorzano
Duplicate of bug:

http://bugs.mysql.com/bug.php?id=14950