Bug #15223 5.0.16/5.0.17/4.1.16 RPM packages provides wrong zlib dependancy
Submitted: 24 Nov 2005 13:53 Modified: 4 Mar 2006 0:55
Reporter: Domas Mituzas Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:5.0.16, 5.0.17, 4.1.16 OS:Linux (Linux)
Assigned to: Kent Boortz CPU Architecture:Any

[24 Nov 2005 13:53] Domas Mituzas
Description:
RHEL4 package has libz.so.0 dependancy.
RHEL4 provides zlib-1.2.1.2-1.2, no .0.

Packages fail to install:

libz.so.0 is needed by MySQL-shared-standard-5.0.16-0.rhel4.i386

How to repeat:
Install MySQL RHEL4 RPMs.

Suggested fix:
use system dependancy or if bundled zlib is used - do not depend on external zlib
[24 Nov 2005 15:26] Brian Aker
I thought we switched to always use the internal zlib to get around these problems?
[24 Nov 2005 22:08] Jeff C
I can confirm this exact bug is happening to me.  Symlinking libz.so.0 to libz.so.1.2.1.2 does not work 

Worked flawlessly in 5.0.15... I hope you guys fix the rpms and republish them immediately, but my guess is 5.0.17.
[26 Nov 2005 12:22] Thomas Keller
A similar problem exists on FC4. Since I just recently got aware of this bug, I "fixed" it by just downgrading to 5.0.15 (I got no dependency error through rpm when installing it in first instance, but major compile problems of 3rd party applications, see bug http://bugs.mysql.com/?id=15255).

This is how my libz* part looks alike:

[root@tidikay lib]# ll libz.*
-rwxr-xr-x  1 root root 94068 22. Jul 10:18 libz.a
lrwxrwxrwx  1 root root    15 28. Jul 17:28 libz.so -> libz.so.1.2.2.2
lrwxrwxrwx  1 root root    15 28. Jul 17:27 libz.so.1 -> libz.so.1.2.2.2
-rwxr-xr-x  1 root root 74120 22. Jul 10:18 libz.so.1.2.2.2

Symlinking libz.so.1.2.2.2 to libz.so.0 didn't work for me either:

mysqlclient -lz -lcrypt -lnsl -lm -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt  -o libphp5.la
grep: /usr/lib/mysql/libz.la: No such file or directory
/bin/sed: can't read /usr/lib/mysql/libz.la: No such file or directory
libtool: link: `/usr/lib/mysql/libz.la' is not a valid libtool archive
make: *** [libphp5.la] Fehler 1

May I ask why the scheme of linking zlib has changed anyways between 5.0.15 and 5.0.16?
[4 Dec 2005 4:15] Roberto Bertó
Same here on a RHEL3
[8 Dec 2005 1:34] Nelson Emery
Nelson Emery  emernel@rogers.com

I am having the same problem with v4 and v5.0.16

has anyone been able to find a fix for this?
[8 Dec 2005 2:19] Roberto Bertó
I downloaded build it from generic linux src.rpm (http://dev.mysql.com/get/Downloads/MySQL-5.0/MySQL-5.0.16-0.src.rpm/from/pick and)
[9 Dec 2005 4:32] Dan Kozlowski
I am using RedHat 9 and have the same problem. I can't seem to migrate from 3.23. to MySQL 5. Any ideas how to remove 2.23 I thought the shared would solve my problem.
[13 Dec 2005 19:23] Derek Hanks
I'm having the same trouble with SUSE Ent 9
[13 Dec 2005 22:28] Derek Hanks
I couldn't find version .15.  I had to go with .13.  It installed without complaining about missing libraries.
[15 Dec 2005 10:55] Adam Roper
Same here on 64-bit RHEL3.

Also get the same problem with MySQL-server-standard-4.1.16-0.rhel3.x86_64.rpm
[15 Dec 2005 10:57] Adam Roper
Oh, and I'm installing 5.0.15, not 5.0.16
[15 Dec 2005 11:00] Adam Roper
Sorry, that's a lie ... it's 5.0.16.  Just ignore me
[15 Dec 2005 13:01] Ivan Chernyavsky
The same on SuSE 9.0

Got devel-5.0.13 and it works (with server-5.0.16, client-5.0.16). At least so far ;)
[15 Dec 2005 13:07] Ivan Chernyavsky
Oh sorry, not really the same. I noticed it when compiling PHP --with-mysqli. It tried to link /usr/lib/mysql/libz.la and that file not exists. Anyway, downgrading "devel" rpm to 5.0.13 I finally compiled PHP.
[15 Dec 2005 21:50] Derek Hanks
Developmnent insists on .16.  What's your opinion of this hack?

mysql1:/usr/lib64 # ls -la libz.*
-rw-r--r--  1 root root 101438 Aug 25  2004 libz.a
lrwxrwxrwx  1 root root     16 Aug 24 23:35 libz.so -> /lib64/libz.so.1
lrwxrwxrwx  1 root root     11 Dec 15 10:03 libz.so.0 -> ./libz.so.1
lrwxrwxrwx  1 root root     10 Aug 24 23:35 libz.so.1 -> libgz.so.1
[15 Dec 2005 22:00] Rodrigo Novo
This bug is fixed for 5.0.17, which shall be available in a few days. (it is in the last build & testing stages right now)

Stay tuned!
[16 Dec 2005 17:12] Steve Meyers
What about the fix for 4.1.16?  If it's a packaging issue, not a code issue, why do we need to wait until the next release to have it fixed?
[17 Dec 2005 16:04] Andrew Craig
I have this exact problem using Cent OS 4.2..What is the fix to it? I installed the previous version of the shared library and the Mysql daemon would not start and I was pointed to another bug report for RHEL 4 (samee thing as Cent OS) that basically said to disable selinux and all would be ok. I did and it wasnt so I have uninstalled and am back at the same problem again!!
I am again getting this error..

Error: Missing Dependency: libz.so.0 is needed by package MySQL-shared-standard

Anyone got a fix as version 5.0.17 is still not released and I have an expensive server sat costing me now!!

Thanks
[17 Dec 2005 16:06] Andrew Craig
Meant also to say. Rodrigo, is there a workaround for this problem that you know of? thanks
[18 Dec 2005 0:53] Jeremy Martin
until they release 5.0.17...

just download the source RPM (*.src.rpm)

install it

then go to /usr/src/redhat/SPECS

and do rpmbuild -ba (spec file)

then your RPMs will be spit out in /usr/src/redhat/RPMS/(platform)/
[18 Dec 2005 1:15] Andrew Craig
THANKS for that useful info Jeremy!
I will do that right now and hopefully will be good to go...cheers
[18 Dec 2005 1:16] Andrew Craig
ps/never known what the source rpms did exactly!! even though Ive compiled a kernel or two in the past!!cheers
[18 Dec 2005 15:54] Andrew Craig
What will building them from source change though if it is still 5.0.16 ??
Surely "all the RPMs" spat out from the main package will be the same as the seperate rpms no??
[18 Dec 2005 22:24] Andrew Craig
Yes. Lack of library dependanies!! got it now.thanks
[19 Dec 2005 21:21] Gary Richardson
This is still a problem on my RHEL3 box using both MySQL-*-5.0.17-0.rhel3.i386.rpm and MySQL-*-5.0.17-0.rhel3.i386.rpm:

[root@dbse-002-dev src]# rpm -Uvh MySQL-*-standard-5.0.17-0.rhel3.i386.rpm
warning: MySQL-client-standard-5.0.17-0.rhel3.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
        libz.so.0 is needed by MySQL-shared-standard-5.0.17-0.rhel3

And the same goes on a RHEL4 box:

[root@burner src]# rpm -Uvh MySQL-*-5.0.17-0.glibc23.i386.rpm
warning: MySQL-client-5.0.17-0.glibc23.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
        libz.so.0 is needed by MySQL-Max-5.0.17-0.glibc23.i386
        libz.so.0 is needed by MySQL-shared-5.0.17-0.glibc23.i386

I've tried compiling the src rpm's for the 5.0.16 release before and that did not fix the problem. Why is this happening? Can I change an include option for ./configure to make this work or will we all have to wait until 5.0.18?
[19 Dec 2005 21:48] [ name withheld ]
I'm still having this problem with version 5.0.17 in RH3.
[19 Dec 2005 21:56] Sean Andrews
Yeah. Me too. I have tried compiling from source 5.0.16 and now the new 5.0.17 from rpms and source....!! What is going on here?? Can someone let us know if they have found a workable solution? This is getting worse....
is there no header info that can be changed or better still a working patch fora critical system....
[20 Dec 2005 0:25] Kent Boortz
We are redoing the 5.0.17 Red Hat 3 packages, generic Linux x86
and the 4.1.16 RPM's. New packages will be up very soon.
Very sorry about this.
[20 Dec 2005 0:34] Sean Andrews
Thanks. This is good to hear. Are you going to be fixing the RHEL 4 rpm's as it will not work on rhel 4 as well as 3. Please let us know as soon as new rpms are up. thanks again
[20 Dec 2005 0:37] Andrew Craig
Yes. I have tried installing from source rpm and I am still having this exact same problem :(
major problem as I cannot downgrade to 4.16 either without getting it and new 5.0.17 rpm sadly has not fixed it???
Please confirm as soon as the rpm for RHEL4 (and 3) and/ or the generic source rpms.

Many Thanks
[20 Dec 2005 0:38] Andrew Craig
addition/// please inform us as soon as any of the rpms have been fixed
[20 Dec 2005 1:08] Andrew Craig
THANKS. Just got it to install with no dependancy problems! Great Work guys
[20 Dec 2005 1:08] Andrew Craig
Thats on RHEL 4 by the way. Fixed I think/hope!
[20 Dec 2005 20:00] Damon B
Have the new files actually been released?  Some of the latest comments seem to suggest that, but I continue to receive the dependency error with Fedora Core 4 and the current generic Linux rpm for MySQL-shared-5.0.17-0:

libz.so.0 is needed by MySQL-shared-5.0.17-0.glibc23.i386
[20 Dec 2005 23:01] christiane chan
It download 30 minutes ago the MySQL-shared-5.0.17-0.glibc23.i386.rpm. I install using  rpm -ivh MySQL-shared-5.0.17-0.glibc23.i386.rpm on red hat professional workstation, but I still having the following error:
error: Failed dependencies:
        libz.so.0 is needed by MySQL-shared-5.0.17-0.glibc23

Please someone send an email to christiane_chan@yahoo.com when it is updated.
Thank you, you guys are doing a great job.
[21 Dec 2005 9:51] Charles Low
I installed minimum FC4 and yum install zlib-devel. Same problem.
[21 Dec 2005 13:48] Lenz Grimmer
As a temporary workaround, you can also try the following:

$ cd /usr/lib
$ ln -s libz.so.1 libz.so.0

Then install the RPM with --nodeps to ignore the libz dependency.
[21 Dec 2005 16:18] v t
Downloaded 5.0.17 rpm's this morning and still get the dependency (libz.so.0 )error: 
see below. Is this bug fixed yet? Apparently doesn't seem like it.
When will this be fixed?
----------------------------------------
# rpm -Uvh MySQL*.rpm
warning: MySQL-client-standard-5.0.17-0.rhel3.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
        libz.so.0 is needed by MySQL-shared-standard-5.0.17-0.rhel3
[21 Dec 2005 18:52] Andrew Craig
Below is my SQL Variables sent to text file after my successful install  (without Zlib error) on Cent OS 4.2 (RHEL 4)...
BUT although mysql seems to work my web server is still down for other reasons (php integration) so I cannot confirm all is great just yet.

+---------------------------------+------------------------------------------+
| Variable_name                   | Value                                    |
+---------------------------------+------------------------------------------+
//////////////////////////////////////////////////////////////////////
cleared as not enough lines fre to show all  |
| net_write_timeout               | 60                                       |
| new                             | OFF                                      |
| old_passwords                   | OFF                                      |
| open_files_limit                | 1024                                     |
| optimizer_prune_level           | 1                                        |
| optimizer_search_depth          | 62                                       |
| pid_file                        | /var/lib/mysql/XXXXXXXX |
| port                            | 3306                                     |
| preload_buffer_size             | 32768                                    |
| protocol_version                | 10                                       |
| query_alloc_block_size          | 8192                                     |
| query_cache_limit               | 1048576                                  |
| query_cache_min_res_unit        | 4096                                     |
| query_cache_size                | 0                                        |
| query_cache_type                | ON                                       |
| query_cache_wlock_invalidate    | OFF                                      |
| query_prealloc_size             | 8192                                     |
| range_alloc_block_size          | 2048                                     |
| read_buffer_size                | 131072                                   |
| read_only                       | OFF                                      |
| read_rnd_buffer_size            | 262144                                   |
| relay_log_purge                 | ON                                       |
| relay_log_space_limit           | 0                                        |
| rpl_recovery_rank               | 0                                        |
| secure_auth                     | OFF                                      |
| server_id                       | 0                                        |
| skip_external_locking           | ON                                       |
| skip_networking                 | OFF                                      |
| skip_show_database              | OFF                                      |
| slave_compressed_protocol       | OFF                                      |
| slave_load_tmpdir               | /tmp/                                    |
| slave_net_timeout               | 3600                                     |
| slave_skip_errors               | OFF                                      |
| slave_transaction_retries       | 10                                       |
| slow_launch_time                | 2                                        |
| socket                          | /var/lib/mysql/mysql.sock                |
| sort_buffer_size                | 2097144                                  |
| sql_mode                        |                                          |
| sql_notes                       | ON                                       |
| sql_warnings                    | ON                                       |
| storage_engine                  | MyISAM                                   |
| sync_binlog                     | 0                                        |
| sync_frm                        | ON                                       |
| sync_replication                | 0                                        |
| sync_replication_slave_id       | 0                                        |
| sync_replication_timeout        | 10                                       |
| system_time_zone                | GMT                                      |
| table_cache                     | 64                                       |
| table_lock_wait_timeout         | 50                                       |
| table_type                      | MyISAM                                   |
| thread_cache_size               | 0                                        |
| thread_stack                    | 196608                                   |
| time_format                     | %H:%i:%s                                 |
| time_zone                       | SYSTEM                                   |
| timed_mutexes                   | OFF                                      |
| tmp_table_size                  | 33554432                                 |
| tmpdir                          |                                          |
| transaction_alloc_block_size    | 8192                                     |
| transaction_prealloc_size       | 4096                                     |
| tx_isolation                    | REPEATABLE-READ                          |
| updatable_views_with_limit      | YES                                      |
| version                         | 5.0.17-standard                          |
| version_comment                 | MySQL Community Edition - Standard (GPL) |
| version_compile_machine         | i686                                     |
| version_compile_os              | pc-linux-gnu                             |
| wait_timeout                    | 28800                                    |
+---------------------------------+------------------------------------------+
[21 Dec 2005 19:27] Kent Boortz
The updated packages has the version/release number 5.0.17-1.
Some are up on dev.mysql.com/downloads/mysql/5.0.html,
there are more to come.

The RHEL4 and SLES9 packages are not affected by this
problem in 5.0.17, the "generic RPMs" and RHEL3 ones are.
[21 Dec 2005 19:41] Scott Marlowe
Does this address bug # 15255 ???
[30 Dec 2005 5:57] Reuben Ng
i have downloaded the 4.1.16-1 i386.glib23 precompiled binary packages (dated december 25th, 2005 from ftp.belnet.be) and installed it; when i tried to compile courier-authlib-0.58 i still had the '/usr/lib/mysql/libz.la not found' error.
[30 Dec 2005 16:47] Sebastin Mueld
I've downloaded 4.1.16-1 i386.glib23 and all other packages (server,client,shared etc.) too and after installing with rpm -Uvh .... there is no libz.la anywhere. 

So I've downgraded to 4.1.10a again and all works.

What's happened here?
[12 Jan 2006 8:51] Aaron
I'm surprised this isn't fixed yet. It looks to be a simple fix.

The error is:
grep: /usr/lib/mysql/libz.la: No such file or directory
/bin/sed: can't read /usr/lib/mysql/libz.la: No such file or directory
libtool: link: `/usr/lib/mysql/libz.la' is not a valid libtool archive
make: *** [libphp5.la] Error 1

Maybe this helps somehow...

libz.la can be found in /usr/lib (not /usr/lib/mysql)

I'm not exactly a programmer, but to me it would seem like that is our little guy.

Anyway, as a temporary fix, I am using MySQL 4.1.16-server and 4.1.16-client, but I am using MySQL 4.1.15-devel. It is working so far.
[12 Jan 2006 23:13] Aaron
I see that in MySQL 5.0.17-1 this was fixed. Why wasn't it fixed in 4.1.16-1?

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-17.html
[4 Mar 2006 0:18] Kent Boortz
This was corrected in 4.1.18 and 5.0.17-1
[4 Mar 2006 0:54] Paul Dubois
Noted in 4.1.18, 5.0.17 changelogs.

RPM packages had an incorrect <literal>zlib</literal>
dependency. (Bug #15223)
[13 Apr 2006 19:53] Paul Slaymaker
I see the same problem in 4.1.18 rpm install compiling php5.1 --with-mysqli.  What would be the problem changing dependencies to system zlib for php compile?
[13 Apr 2006 19:55] Aaron
I'm not sure why this bug was closed, because it's not fixed... but here is another bug report about the same issue:

http://bugs.mysql.com/bug.php?id=18294
[13 Apr 2006 20:20] Scott Marlowe
I was able to successfully build the mysql client interface libs on my Fedora Core 2 machine.

MySQL:  5.0.19
PHP: 5.1.2
Apache: 2.0.51
PostgreSQL: 7.4.8
Oracle instant client: 10.1.0.4

with the --mysql switch.  My configure options looked like this:

--with-oci8=instantclient,/usr/lib/oracle/10.1.0.4/client/lib/ 
--enable-sigchild 
--with-pgsql 
--with-apxs2=/usr/sbin/apxs 
--enable-memory-limit 
--with-ldap 
--with-ldap-sasl 
--with-mysql 
--with-gd 
--with-zlib 

Note that this was NOT with mysqli, just plain mysql.  And I can connect to all three database servers this way reliably.
[11 Jun 2006 0:28] Jesus Lara
i built zlib from source (dynamic and static links):
        libz.so.1 (libc6) => /usr/lib/libz.so.1
        libz.so (libc6) => /usr/lib/libz.so
and /usr/lib/libz.a too; but mysql 5.1.11-beta compilation fail with this error:
libtool: link: cannot find the library `../zlib/libz.la' or unhandled argument `../zlib/libz.la'
make[2]: *** [libmysqlclient_r.la] Error 1
if i use a absolute reference to the system zlib instead:
LDFLAGS="-L/usr/local/zlib/lib -lz"
Fail with this error:
/usr/lib/gcc/i386-redhat-linux/4.1.0/../../../crt1.o: In function
`_start': undefined reference to `main'
mysql_tzinfo_to_sql.o: In function
`Time_zone_utc::gmt_sec_to_TIME(st_mysql_time*, long)
const':mysql_tzinfo_to_sql.cc:(.text+0x7bd): undefined reference to
`localtime_to_TIME(st_mysql_time*, tm*)'
mysql_tzinfo_to_sql.o: In function
`Time_zone_system::gmt_sec_to_TIME(st_mysql_time*, long)
const':mysql_tzinfo_to_sql.cc:(.text+0x81d): undefined reference to
`localtime_to_TIME(st_mysql_time*, tm*)'mysql_tzinfo_to_sql.o: In
function `Time_zone_system::TIME_to_gmt_sec(st_mysql_time const*,
char*) const':mysql_tzinfo_to_sql.cc:(.text+0x867): undefined reference
to `my_system_gmt_sec'
mysql_tzinfo_to_sql.o: In function `my_tz_find(String const*,
st_table_list*)':mysql_tzinfo_to_sql.cc:(.text+0xfbd): undefined
reference to `sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x1034): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x11e5): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x11fa): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x1214): undefined reference to
`sql_print_error(char const*, ...)'
mysql_tzinfo_to_sql.o:mysql_tzinfo_to_sql.cc:(.text+0x13a8): more
undefined references to `sql_print_error(char const*, ...)' follow
mysql_tzinfo_to_sql.o: In function `my_tz_init(THD*, char const*,
char)':mysql_tzinfo_to_sql.cc:(.text+0x1bc1): undefined reference to
`THD::THD()'
:mysql_tzinfo_to_sql.cc:(.text+0x1be2): undefined reference to
`THD::store_globals()'
:mysql_tzinfo_to_sql.cc:(.text+0x1c32): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x1c57): undefined reference to
`THD::store_globals()'
:mysql_tzinfo_to_sql.cc:(.text+0x1dc7): undefined reference to
`global_system_variables'
:mysql_tzinfo_to_sql.cc:(.text+0x1e05): undefined reference to
`close_thread_tables(THD*, bool, bool)'
:mysql_tzinfo_to_sql.cc:(.text+0x1e36): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x1e4f): undefined reference to
`THR_THD'
:mysql_tzinfo_to_sql.cc:(.text+0x1e65): undefined reference to
`THR_MALLOC'
:mysql_tzinfo_to_sql.cc:(.text+0x1e8a): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x202c): undefined reference to
`simple_open_n_lock_tables(THD*, st_table_list*)'
:mysql_tzinfo_to_sql.cc:(.text+0x204a): undefined reference to
`sql_print_warning(char const*,
...)':mysql_tzinfo_to_sql.cc:(.text+0x213b): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x2183): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x21a4): undefined reference to
`sql_print_error(char const*, ...)'
:mysql_tzinfo_to_sql.cc:(.text+0x21c9): undefined reference to
`sql_print_error(char const*, ...)'
mysql_tzinfo_to_sql.o: In function
`my_tz_find_with_opening_tz_tables(THD*, String
const*)':mysql_tzinfo_to_sql.cc:(.text+0x273d): undefined reference to
`simple_open_n_lock_tables(THD*, st_table_list*)'
:mysql_tzinfo_to_sql.cc:(.text+0x2770): undefined reference to
`close_thread_tables(THD*, bool, bool)'
collect2: ld returned 1 exit status
make[4]: *** [mysql_tzinfo_to_sql] Error 1
make[4]: Leaving directory `/usr/local/src/mysql-5.1.11-beta/sql'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/local/src/mysql-5.1.11-beta/sql'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/local/src/mysql-5.1.11-beta/sql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/mysql-5.1.11-beta'
make: *** [all] Error 2

if built mysql erasing any reference of system zlib (using --with-zlib-dir=bundled) the system compile fine ... 
mysql 5.1.11 prefers a "bundled version" of zlib instead a system version?

PHP and apache using a system Zlib ... , mysql extension work but mysqli extension in PHP fails ...

Mysql will not use a system zlib anymore to be built from source?

I have installed these dependencies packages:
gcc (GCC) 4.1.0 20060304
autoconf (GNU Autoconf) 2.59
automake (GNU automake) 1.9.6
zlib 1.2.3 (compiled from myself).
OpenSSL 0.9.8a 11 Oct 2005
glibc-2.4-8
[11 Jun 2006 1:33] Jesus Lara
i edited this lines of Makefile and libmysql_r/Makefile, libmysql/Makefile (and others locations):
From:
LIBS = -lcrypt -lnsl -lm  -L/usr/local/ssl/lib/ -lssl -lcrypto $(top_builddir)/zlib/libz.la  
ZLIB_INCLUDES = -I$(top_srcdir)/zlib
ZLIB_LIBS = $(top_builddir)/zlib/libz.la
openssl_includes = -I
openssl_libs = -L/usr/local/ssl/lib/ -lssl -lcrypto
To:
LIBS = -lcrypt -lnsl -lm  -L/usr/local/ssl/lib/ -lssl -lcrypto -L/usr/local/zlib/lib -lz
ZLIB_INCLUDES = -I/usr/local/zlib/include
ZLIB_LIBS = /usr/local/zlib/lib/libz.a
CLIENT_LIBS = -lcrypt -lnsl -lm  -L/usr/local/ssl/lib/ -lssl -lcrypto -L/usr/local/zlib/lib -lz
openssl_includes = -I/usr/local/ssl/include/openssl
openssl_libs = -L/usr/local/ssl/lib/ -lssl -lcrypto
----
Then, Compilation problems dissapear.
I try to pass this Compilation Variables in mySQL Compilation Sentence:
CXXFLAGS="-O3 -fPIC -pthread -mtune=pentium-m -march=pentium-m -pipe -fomit-frame-pointer -msse3 -fno-exceptions -fno-rtti -m32 -fno-strict-aliasing" C_EXTRA_FLAGS="-fno-strict-aliasing" \
LDFLAGS="-L/usr/local/zlib/lib -lz -L/usr/local/ssl/lib -L/usr/local/BerkeleyDB.4.4/lib" \
CPPFLAGS="-I/usr/local/zlib/include -I/usr/local/ssl/include/openssl -I/usr/local/BerkeleyDB.4.4/include" \
ZLIB_INCLUDES = "-I/usr/local/zlib/include" ZLIB_LIBS = "/usr/local/zlib/lib/libz.a" \
MYSQLD_EXTRA_LDFLAGS ="-L/usr/local/zlib/lib -lz -L/usr/local/ssl/lib -lssl -lcrypto" \
./configure --prefix=/usr/local/mysql  --with-mysqlmanager --with-mysqld-user=mysql \
--libexecdir=/usr/local/mysql/bin --sysconfdir=/usr/local/mysql/etc --with-unix-socket-path=/tmp/mysql.sock \
--datadir=/usr/local/mysql/share --localstatedir=/usr/local/mysql/data \
--without-debug --without-man --without-docs --with-tcp-port=3306 \
--enable-assembler --enable-shared --enable-static --with-gnu-ld \
--with-ssl=/usr/local/ssl --with-zlib \
--enable-thread-safe-client --enable-local-infile --with-extra-tools --enable-java \
--with-innodb  --with-archive-storage-engine --with-cvs-storage-engine \
--with-embedded-privilege-control --with-embedded-server
----
This "Big" Sentence compile fine in my Linux Fedora Core 5.