Bug #14355 Partitions: SHOW ENGINES shows partition=no
Submitted: 26 Oct 2005 20:16 Modified: 20 Jan 2006 1:45
Reporter: Peter Gulutzan Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Partitions Severity:S3 (Non-critical)
Version:5.1.2-alpha-debug OS:Linux (SUSE 10.0)
Assigned to: Mikael Ronström CPU Architecture:Any

[26 Oct 2005 20:16] Peter Gulutzan
Description:
The partition feature is called an "engine". So when I
say "show variables like '%partition%'" I see
have_partition_engine=YES. But when I say "show engines"
I see "partition=NO. I would consider it a good "fix"
if everyone stopped calling partitions an engine.

How to repeat:
mysql> show variables like '%partition%';
+-----------------------+-------+
| Variable_name         | Value |
+-----------------------+-------+
| have_partition_engine | YES   |
+-----------------------+-------+
1 row in set (0.00 sec)

mysql> show engines;
+------------+----------+------------------------------------------------------------------------+
| Engine     | Support  | Comment                                                                |
+------------+----------+------------------------------------------------------------------------+
| MEMORY     | YES      | Hash based, stored in memory, useful for temporary tables              |
| MyISAM     | DEFAULT  | Default engine as of MySQL 3.23 with great performance                 |
| InnoDB     | YES      | Supports transactions, row-level locking, and foreign keys             |
| BerkeleyDB | YES      | Supports transactions and page-level locking                           |
| ARCHIVE    | YES      | Archive storage engine                                                 |
| CSV        | YES      | CSV storage engine                                                     |
| BLACKHOLE  | YES      | /dev/null storage engine (anything you write to it disappears)         |
| FEDERATED  | YES      | Federated MySQL storage engine                                         |
| ndbcluster | DISABLED | Clustered, fault-tolerant, memory-based tables                         |
| partition  | NO       |                                                                        |
| MRG_MYISAM | YES      | Collection of identical MyISAM tables                                  |
| binlog     | DISABLED | This is a meta storage engine to represent the binlog in a transaction |
+------------+----------+------------------------------------------------------------------------+
12 rows in set (0.00 sec)
[31 Oct 2005 22:05] Mikael Ronström
Completely agree with the comment but still not a bug
[31 Oct 2005 22:13] Mikael Ronström
By closer thought one should ensure that the partition engine is not listed
in show engines.
[2 Nov 2005 18:53] Mikael Ronström
Partition engine and Binlog is now not shown in SHOW ENGINES command.
Also changed name on have_partition_engine to have_partition_support
[19 Jan 2006 9:18] Mikael Ronström
Fixed, will at least appear in 5.1.6
[20 Jan 2006 1:45] Paul Dubois
Noted in 5.1.6 changelog.

          Partition support is not an <quote>engine</quote>, but it was
          included in the output of <literal>SHOW ENGINES</literal>. Now
          it does not. (Bug #14355)